# Table of Contents

1. Introduction to Additive Manufacturing ................................................................. 1  
2. AM Process Simulation in ANSYS Workbench ...................................................... 3  
3. Preparing the Part for Simulation ....................................................................... 7  
4. AM Process Simulation Workflow - With the Additive Wizard ......................... 11  
   4.1. Create the Analysis System ........................................................................... 11  
   4.2. Define Engineering Data ............................................................................. 12  
   4.3. Attach Geometry and Launch Mechanical ................................................. 13  
   4.4. Identify Geometry (First Page of Additive Wizard) ...................................... 14  
   4.5. Generate Mesh and Contact Connections (Second Page of Additive Wizard) .................................................................................................................. 16  
   4.6. Generate Supports (Third Page of Additive Wizard) .................................. 17  
   4.7. Assign Materials (Fourth Page of Additive Wizard) ................................... 18  
   4.8. Define AM Process Settings and Sequence Steps (Fifth Page of Additive Wizard) ................................................................................................................. 20  
   4.9. Apply Boundary Conditions (Sixth Page of Additive Wizard) .................... 27  
   4.10. Solve the Transient Thermal Analysis ....................................................... 29  
   4.11. Solve the Static Structural Analysis .......................................................... 30  
   4.12. Review Results ........................................................................................ 30  
5. AM Process Simulation Workflow - Without the Additive Wizard .................. 37  
   5.1. Create the Analysis System ............................................................................ 37  
   5.2. Define Engineering Data ............................................................................... 38  
   5.3. Attach Geometry and Launch Mechanical ................................................. 39  
   5.4. Identify Geometry ....................................................................................... 42  
   5.5. Assign Materials ......................................................................................... 43  
   5.6. Apply Mesh Controls and Generate Mesh .................................................. 44  
   5.7. Identify and/or Generate Supports ............................................................. 51  
   5.8. Define Connections ..................................................................................... 58  
   5.9. Define AM Process Steps ............................................................................ 62  
   5.10. Define Build Settings .................................................................................. 65  
   5.11. Establish Thermal Analysis Settings .......................................................... 67  
   5.12. Apply Thermal Boundary Conditions ........................................................ 67  
   5.13. Solve the Transient Thermal Analysis ........................................................ 69  
   5.14. Establish Structural Analysis Settings ........................................................ 69  
   5.15. Apply Structural Boundary Conditions ..................................................... 70  
   5.16. Solve the Static Structural Analysis ............................................................ 72  
   5.17. Review Results ........................................................................................ 72  
6. Advanced Topics .................................................................................................. 79  
   6.1. Using Topology Optimization for Additive Manufacturing ......................... 79  
   6.2. Using the Inherent Strain Method ................................................................. 84  
   6.3. Performing a Directed Energy Deposition (DED) Process Simulation ........ 86  
   6.4. Simulating Heat Treatment after the Build .................................................. 87  
   6.5. Capturing a Buckled Shape with Large Deflection ..................................... 92  
   6.6. Modeling a Symmetrical Part ...................................................................... 94  
   6.7. Modeling Powder with Elements ............................................................... 97  
   6.8. Modeling Clamps, Measuring Devices and Other "Non-Build" Components .................................................................................................................. 99  
   6.9. Using Beam Bonded Contact to Connect a Tet-meshed Part to STL Supports .................................................................................................................. 99  
   6.10. Troubleshooting Convergence Issues ........................................................ 101
Chapter 1: Introduction to Additive Manufacturing

Additive manufacturing (3D printing) can be a cost-effective way of producing parts, especially when making use of the design freedoms the manufacturing process enables, such as topological complexity and the ability to print assemblies in one step.

Metal additive manufacturing is used to produce parts for aerospace, automotive, medical and other industries. These are high-value parts that require careful design and manufacturing, and simulation has long been used to validate the as-built part performance.

The additive process for metals introduces inherent complexities and challenges, however, such that the process itself requires simulation to successfully produce the parts.

Additive Manufacturing Processes

Additive manufacturing (AM) is classified into a number of processes, most of which are applicable to polymers. Two are the primary processes for fully-dense (no porosity) production of metal parts: powder bed fusion (PBF) and directed energy deposition (DED). Our focus is on modeling these two processes.

In a powder bed fusion process – also known as direct metal laser melting (DMLM), direct metal laser sintering (DMLS), or selective laser melting (SLM) – a thin layer of metal powder is deposited and a highly focused laser beam of energy is moved over its surface in order to melt the metal powder composing the current cross section and fusing it to the preceding layer. A solid part emerges as successive layers are deposited and processed. The initial layer is deposited on a build plate or substrate.

In a directed energy process (DED) – also known as laser engineered net shaping (LENS), electron beam additive manufacturing (EBAM®), or laser deposition technology (LDT) – a laser or electron beam creates a melt pool on previously solidified material where blown powder or fed wire is introduced to add material.

Both of these processes produce high temperatures and severe thermal gradients, leading to significant distortion and buildup of residual stresses as the layers are deposited. The distortion can be high enough to interfere with the application of the next layer, and the residual stresses high enough to break the part off the build plate or off its supports, or crack the part itself. Additionally, the residual stresses will produce more distortion when the part is removed from the build plate and its supports removed leading to an undesirable final shape.

How Simulation Can Assist with AM Challenges

Being able to simulate these distortions and stresses during the design of the part will help prevent failed builds and lead to better designs for additive manufacturing.

Supports are generally needed to anchor and support overhangs and other horizontal (and nearly horizontal) surfaces such as the tops of holes. They are also used to control distortions and provide heat transfer routes during the build. Supports add cost – material, build time, and removal effort – so their use should be minimized. Simulation can be used to determine the best build orientation for a part,
best locations for supports, and support sizing requirements. Simulation is particularly powerful when used with topology optimization to minimize overhang regions requiring supports.
Chapter 2: AM Process Simulation in ANSYS Workbench

ANSYS Additive Suite is a powerful collection of tools from ANSYS, Inc. dedicated to additive manufacturing simulation. Workbench Additive is one of those tools, designed to work within ANSYS Workbench and the ANSYS Mechanical application.

Target Users

Target users of Workbench Additive are the engineers involved in the design and analysis of mechanical components, not necessarily manufacturing engineers and technicians tasked with printing the parts on the machine floor, nor the R&D researchers responsible for determining the ideal printing machine process parameters. Current users of ANSYS SpaceClaim and ANSYS Workbench/Mechanical will benefit greatly from running AM Process Simulations if they plan to use additive manufacturing to print their metal parts.

Simulation Goals

The goal of AM Process Simulation in ANSYS Workbench is to predict the macro-level distortions and stresses in parts to prevent build failures and provide trend data for improving designs for additive manufacturing including part orientation and support placement and sizing.

The simulation is not meant to provide detailed thermal or structural results needed for prediction of micro-level process phenomena (i.e., microstructure). The simulation will also not provide detailed guidance on the setting of the machine’s process parameters. Our complementary offerings of ANSYS Additive Print and Additive Science (within Additive Suite) are the products to use to achieve those goals.

Methodology and Abstractions

Simulation of the manufacturing process requires that the analysis follows the build process itself: layer-by-layer solidification of the part. Since the thermal (temperatures) and structural (distortion and stress) physics are largely uncoupled (i.e., a weak coupling), we can simulate the thermal phenomena first, layer-by-layer, and use those temperature results in a following structural simulation.

In an AM Process Simulation, the model evolves over time; that is, elements are added. We actually mesh the entire part first with a layered mesh (either Cartesian or Tetrahedrons) and then use the standard element birth and death technique to “turn on” element layers to simulate the build progressing. Additionally, the relevant boundary conditions also evolve such as thermal convection surfaces. The build step is complete when all the element layers have been added (made "alive").

The analysis times and time stepping are also driven by the process parameters and are not known a priori. These details are all handled internally during the solution.

Simulating the entire build process for a real part following the beam scan pattern would take enormous compute time making it impractical. To meet our goals in a reasonable compute time – meaning much less than the actual build time – we use the following abstractions:
**Super layers:** Actual metal powder deposit layers are aggregated into finite element “super layers” for simulation purposes. Since the temperature histories of each adjacent layer is similar, this lumping approach is appropriate. Note: The real machine build time is approximately the transient thermal build step simulation time multiplied by $R^{(1/3)}$, where $R$ is the number of deposit layers in one element super layer.

**Layer-by-layer addition:** Material is added and heated all at once for each element layer. For current generation machines and their scan patterns, this is a reasonable assumption. The in-plane thermal effects do not contribute to the distortion as much as the build direction thermal effects. This means we do not use scan pattern information as input.

**Applied temperature:** Rather than applying heat flux, the entire layer is initially set to the melt temperature. The assumption is that the process parameters for the build have been set appropriately so that (1) the developed temperature is always at or above melt (no lack of fusion) and (2) the developed temperature does not greatly exceed melt (no keyholing).

**Time step size:** Large integration time step sizes are used throughout the simulation. This is sufficient to capture the induced thermal and plastic strains driving the distortion. The localized smooth heating and cooling curves will not be captured in detail.

**Supports:** Supports are represented as an orthotropic homogenized solid. While you can provide detailed support geometry, modeling this way is sufficient to capture part distortion and obtain estimates of support failure.

**Surrounding powder:** For the powder bed process, the surrounding unmelted powder need not be explicitly modeled. Instead, the heat loss into the powder can be accounted for in a simplified approach using a convective boundary condition at the interface between powder and solid material.

## The Additive Wizard

We have customized the procedure for performing an AM Process Simulation into an easy-to-use wizard accessible from within the Mechanical application. If you are new to ANSYS Workbench/Mechanical, or if you are an occasional user, we highly recommend you use the wizard. The workflow is described in AM Process Simulation Workflow - With the Additive Wizard (p. 11). We also recommend you read Mechanical Application Interface in the Mechanical User’s Guide.

Existing users of ANSYS Workbench/Mechanical may also want to try the Additive Wizard to simplify the simulation process. We recommend you do so, as the wizard is an excellent tool to keep you on track and prevent you from missing a task. There are a few capabilities that are not available in the Additive Wizard but you can easily modify your simulation set-up when you complete the wizard as it does not include a solve. Should you decide not to use the wizard, skip the wizard chapter and read AM Process Simulation Workflow - Without the Additive Wizard (p. 37) for the procedure.

## Elements, Commands, and Interface Objects Used in AM Process Simulations

When using ANSYS Workbench/Mechanical to solve a simulation, there is a programming language being used behind the interface, so-to-speak. The following tables show the primary elements, commands, and interface objects used in AM Process Simulations. These items are well documented in our reference guides and links are provided.

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLID70</td>
<td>3D 8-node thermal solid element (Cartesian mesh)</td>
</tr>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SOLID185</td>
<td>3D 8-node structural solid element (Cartesian mesh)</td>
</tr>
<tr>
<td>SOLID87</td>
<td>3D 10-node tetrahedral thermal solid (Tetrahedrons mesh)</td>
</tr>
<tr>
<td>SOLID187</td>
<td>3D 10-node tetrahedral structural solid (Tetrahedrons mesh)</td>
</tr>
<tr>
<td>CONTA174</td>
<td>3D 8-node surface-to-surface contact element</td>
</tr>
<tr>
<td>TARGE170</td>
<td>3D target segment</td>
</tr>
<tr>
<td>SURF152</td>
<td>3D thermal surface effect</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMBEAM</td>
<td>For multiple-beam printers, specifies the number of beams.</td>
</tr>
<tr>
<td>AMBUILD</td>
<td>Specifies printer parameters for the build and other options.</td>
</tr>
<tr>
<td>AMCONNECT</td>
<td>Connects a layered tetrahedral part to voxel-meshed STL supports. (This as a macro, not a command.)</td>
</tr>
<tr>
<td>AMENV</td>
<td>Specifies the build-environment thermal boundary conditions.</td>
</tr>
<tr>
<td>AMMAT</td>
<td>Specifies the build-material melting temperature.</td>
</tr>
<tr>
<td>AMPOWDER</td>
<td>Specifies the powder thermal conditions.</td>
</tr>
<tr>
<td>AMSTEP</td>
<td>Specifies the build-sequence steps.</td>
</tr>
<tr>
<td>AMSUPPORTS</td>
<td>Specifies the information about supports.</td>
</tr>
<tr>
<td>AMTYPE</td>
<td>Specifies the printing process, PBF or DED.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Interface Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Settings</td>
<td>Defines settings and conditions related to the AM machine and the process.</td>
</tr>
<tr>
<td>Cartesian Mesh</td>
<td>Creates a layered Cartesian mesh.</td>
</tr>
<tr>
<td>Create Build to Base Contact</td>
<td>Sets up contact between the build and the base plate that is based on element face selections at the top of the base.</td>
</tr>
<tr>
<td>Generated Support</td>
<td>Creates a support structure consisting of finite elements.</td>
</tr>
<tr>
<td>Layered Tetrahedrons Method Control</td>
<td>Creates a layered Tetrahedrons mesh.</td>
</tr>
<tr>
<td>Predefined Support</td>
<td>Identifies a support structure that was imported with CAD geometry.</td>
</tr>
<tr>
<td>STL Support</td>
<td>Allows you to import and mesh a support structure that is an STL (Stereolithography) file, of either volumeless or solid type.</td>
</tr>
<tr>
<td>Support Group</td>
<td>Used to group Predefined Support objects and Generated Support objects.</td>
</tr>
</tbody>
</table>

**Restrictions and Limitations**

A Workbench Additive Manufacturing Process Simulation is not meant to be used in conjunction with any of these features: gasket elements, fracture, and remote boundary conditions.

When using Workbench scripting to open SpaceClaim and then use Additive Prep, the Additive tab may be missing and/or the tools in the Additive ribbon may be grayed out.
High Performance Computing

An AM Process Simulation can be very compute intensive. We recommend you use high performance computing using an ANSYS HPC license to take advantage of more than four cores.
Chapter 3: Preparing the Part for Simulation

There are several Design for Additive Manufacturing (DfAM) considerations to be aware of that affect the cost and quality of your part. Variables include:

- Part design (thicknesses, overhangs, edges, holes, desired surface finish)
- Orientation on the base plate (affects time to print, number of support structures, and number of replicate parts that can be nested on a base plate)
- Support structures (serve to stabilize part, lower deformations, conduct heat away from part, but more supports increases print and finishing time and cost)

In particular for support structures, you should think ahead about how you will remove them. In some cases you may even need to design tooling rails onto the part in order to be able to hold the part while supports are removed.

Location of Supports

In SpaceClaim, under the Facets tab, use the Overhangs tool to detect where supports will be generated. This is a very useful tool to determine, in advance, overhang locations that may need supports.

Cleanup of Facets

If you have an .stl file, be sure to clean it up to eliminate gaps and slivers before importing it into ANSYS Workbench.

Under Facets, the Check Facets and the Auto Fix tools are quick ways to find and fix problems in faceted bodies.

Use Facets > Thickness to identify thin-walled features.

To Share Topology or Not?

The requirement that geometric bodies be meshed in uniform layers in the Z direction is unique to additive manufacturing simulations. These uniform mesh layers must be conformal even for multi-body parts or geometries consisting of separate part and support bodies. That is, not only must faces, edges and vertices among different bodies to be 3D printed be aware of each other in order to share information in the simulation, they must also be sliced into layers sharing the same step sizes in the Z direction. Together, the part and the supports constitute “the build.”

Two methods in the Mechanical application are available to achieve these uniform mesh layers, one using a Cartesian (brick) mesh and one using a Layered Tetrahedrons mesh. Whether you share topology between bodies in the build—or not—upstream in the CAD program depends on which of these mesh methods you will use.

Use the following criteria for deciding which type of mesh method to use:
· **Use a Layered Tetrahedrons mesh if:**
  - Your geometry has thin walled features, organic curves, and/or holes.

· **Use a Cartesian mesh if:**
  - Your geometry is blocky or chunky without fine features or holes.
  - You know you will be generating supports in ANSYS Mechanical. (Auto-generated supports are not supported with the layered Tetrahedron mesh method.)

Once you've decided which type of mesh method to use, use one of the following approaches, as appropriate.

· **If using a Layered Tetrahedrons mesh:**
  - Do not share topology in the CAD program. To do this in SpaceClaim, under the **Workbench** tab, use the **Unshare** tool to unshare coincident topology.
Or use **Explode Part** in DesignModeler.

**If using a Cartesian mesh:**

- Select all bodies that are associated with the part and the supports and *share coincident topology*. To do this in SpaceClaim, under the **Workbench** tab, use the **Share** tool to share coincident topology. See the video tutorial, **Share Topology** for a step-by-step guide.
Click an object. Double-click to select an edge loop. Triple-click to select a solid.

Pink edges show shared topology
Chapter 4: AM Process Simulation Workflow - With the Additive Wizard

This section describes the overall workflow involved when performing an additive simulation with the Additive Wizard. The wizard automatically adds objects in the project tree as needed. You can exit the Additive Wizard at any time and continue setting up your simulation manually in the project tree.

The following workflow steps are described:

4.1. Create the Analysis System
4.2. Define Engineering Data
4.3. Attach Geometry and Launch Mechanical
4.4. Identify Geometry (First Page of Additive Wizard)
4.5. Generate Mesh and Contact Connections (Second Page of Additive Wizard)
4.6. Generate Supports (Third Page of Additive Wizard)
4.7. Assign Materials (Fourth Page of Additive Wizard)
4.8. Define AM Process Settings and Sequence Steps (Fifth Page of Additive Wizard)
4.9. Apply Boundary Conditions (Sixth Page of Additive Wizard)
4.10. Solve the Transient Thermal Analysis
4.11. Solve the Static Structural Analysis
4.12. Review Results

4.1. Create the Analysis System

An AM Process Simulation requires a linked transient thermal analysis followed by a static structural analysis. For simplification, we assume the physics are uncoupled in that data flows one-way from the thermal analysis to the structural.

1. In ANSYS Workbench, select the Extensions menu, select Manage Extensions, and then select Additive Wizard from the Extensions Manager dialog. Close the dialog.

2. After a few seconds the Additive Manufacturing System button appears (below the Main Menu bar). Click the Additive Manufacturing System button to bring up a linked AM Thermal Analysis and AM Structural Analysis.
Note that the Additive Manufacturing System is available only if you have an ANSYS Additive Suite software license with ANSYS Mechanical Enterprise or one of the multiphysics bundles. If Additive Wizard is grayed out, check your software license.

4.2. Define Engineering Data

The simulation requires a material with a melting temperature specifically defined. We recommend using temperature-dependent properties covering the range from room temperature to melt temperature. For the thermal analysis, the properties required are thermal conductivity, density, and specific heat. For the structural analysis we require Young's Modulus, Poisson's Ratio, coefficient of thermal expansion, and a plasticity model, such as bilinear isotropic hardening. The following popular AM materials for AM are provided as samples in the ANSYS Additive Materials library:

- 17-4PH Stainless Steel
- 316 Stainless Steel
- AlSi10Mg Aluminium alloy
• Inconel 625
• Inconel 718
• Ti-6Al-4V Titanium alloy

Procedural Steps

If you plan to use one of the ANSYS pre-defined AM materials, you will select one later in the Additive Wizard. Skip ahead to the next step.

For general information on how to include custom materials, see Material Data. A nominal strength should be provided at the melt temperature, as a near zero modulus and/or yield strength could lead to convergence problems. (ANSYS pre-defined materials take care of this internally.)

4.3. Attach Geometry and Launch Mechanical

Go directly to procedural steps. (p. 14)

Geometry can be imported directly from CAD or can be from an .stl file as long as they are closed volumes. At a minimum, your simulation must include these geometries:

• **Part** – This is the part you are manufacturing.
  
  – The part geometry should be a closed volume (i.e., watertight), and should be oriented with the global Z axis as the build direction. It may be modeled either resting on the base plate (Z=0), or elevated off the base plate by supports.
  
  – The part can be made of multiple bodies but must have boundaries that are aware of each other in order to assure a proper mesh throughout the part. This is achieved through either shared topology or contact connections, depending on your meshing approach, as you will learn later.
  
  – Usually only one part is simulated even if there will be many duplicate parts nested on the base plate for efficiency. (A multiplier on the build time should be used if this is the case, as described in Machine Settings (p. 20).)

• **Base Plate** – This is the platform on which the build (part plus supports) is to be printed. It is included in the simulation because it acts as a heat sink.
  
  – You can create the base plate ahead of time in the CAD program, or wait to create it in the Mechanical application.
  
  – The base plate may be a different material than the part.

Other geometric bodies that may or may not be simulated include:

• **Support Structures** – Supports are needed to anchor overhanging part features so they do not break away from the platform during the 3D print process because of residual stress buildup. Overhanging features are usually those with angles less than 45° to the horizontal X-Y plane. Together, the part and the supports constitute the build.
  
  – You can create supports ahead of time in the CAD program or support generation tool, or wait to create those bodies in the Mechanical application. If supports are created in CAD, the part and support bodies should be kept as separate bodies (i.e., not merged) so that they may be distinguished as
such in the AM simulation in Mechanical. Whether you set the bodies to "share topology" in the CAD
program depends on whether you will be using a Cartesian mesh or a Layered Tetrahedrons mesh
in the simulation in Mechanical. See To Share Topology or Not? (p. 7) for a discussion about this
topic. When everything is imported into Workbench, you will later identify the support bodies as
predefined supports. Alternatively, you may choose to not include supports when you attach the
part but import the supports separately later (outside of the Wizard) as .stl files.

- Supports must be the same material as the part.

- **Powder** – Modeling the powder may be useful if you will be simulating multiple parts close together
  on the build plate or if the part has features close together, where accounting for the heat transfer oc-
curring between the parts or features is important. Create a separate, closed-volume (watertight) body
to represent the powder in-between multiple parts or in-between features of the same part.

- **Non-build Components** – At times you may want to simulate geometry items that are present on the
  build plate but that are not being 3D-printed. These items may include clamps, bolts, measuring devices,
instrumentation, etc. They may influence the heat dissipation and/or distortion of the part being built
so they need to be included in the simulation. Details of how to model non-build components (p. 99)
are found in Advanced Topics.

### Procedural Steps

Commonly imported file types include SpaceClaim (.scdoc) files and stereolithography (.stl) files. See

1. Right-click the **Geometry** cell of the AM Thermal Analysis, and select Import Geometry. Browse for your
   file and import it. (Note that double-clicking the Geometry cell opens SpaceClaim.)

2. After importing geometry, double-click the **Model** cell (or right-click, and select **Edit**) of the AM Thermal
   Analysis to launch the Mechanical application.

Your geometry must include the part to be printed, but can also include the base plate and/or supports,
as well as powder around the part and any non-build geometry. Alternatively, you can create the base
plate and supports in Mechanical if they are not in the CAD file. Commonly imported file types include
SpaceClaim (.scdoc) files and stereolithography (.stl) files. See Attach Geometry/Mesh in the Mechanical
User's Guide for other options.

1. Right-click the **Geometry** cell of the AM Thermal Analysis, and select Import Geometry. Browse for your
   file and import it. (Note that double-clicking the Geometry cell opens SpaceClaim.)

2. After importing geometry, double-click the **Model** cell (or right-click, and select **Edit**) of the AM Thermal
   Analysis to launch the Mechanical application.

Once the Mechanical application opens, it is a good time to adjust the number of processors (cores)
you are using on your computer. Depending on the complexity of your model, AM Process Simulations
may be computer intensive. If you have an ANSYS HPC license, access the option in the Solve group
on the Home tab and change the **Cores** to something appropriate for your simulation.

### 4.4. Identify Geometry (First Page of Additive Wizard)

**First page of the Additive Wizard:** On the imported geometry, identify which bodies are associated
with the part, supports, base plate, powder, and non-build items. If you want supports to be automatic-
ically created for you, or if you don’t want supports in your model, indicate that here. If your geometry
from CAD does not include a base plate, create one here. If your part is symmetrical and you want to take advantage of symmetry, indicate that here.

**Procedural Steps**

1. Once the Mechanical application opens, select the **Automation** tab, click **Open Wizard** to bring up the Additive Wizard, and then click **Additive Wizard** in the wizard panel once again.

2. The first page of the Additive Wizard requires you to identify which bodies are which for the part, supports, base, powder, and non-build items. Either use the mouse to select a body (geometry selection) or identify a Named Selection. To select a body, be sure that your mode of selection is on body (rather than on face, edge, or vertex). Use the Ctrl key while clicking the left mouse button to select multiple entities. If you choose to have the application create supports automatically, that happens later. If you choose to create the base, fields appear for you to enter overall dimensions of the base and coordinates for the center of the top of the base.

   Use geometry selection (or a named component) to identify symmetry surfaces.

   a. If your model has symmetry, choose **Yes** from the dropdown. No is the default.

   b. Select the symmetry faces at the symmetry plane. Click **Apply**.

   c. Enter a number for the fraction of the whole geometry that is being modeled; 0.5 for half symmetry, 0.25 for quarter symmetry, and so on.

3. Click **Next**.

After identifying the bodies and clicking Next on the wizard page, notice that a new object, the AM Process object, has been added to the project tree. Objects in the tree will be changed or added at several points as you progress through the wizard. It is a good idea to occasionally select the objects in the tree from top to bottom and review the Details view for each object to see how the options you specified in the wizard are implemented in the project tree.
4.5. Generate Mesh and Contact Connections (Second Page of Additive Wizard)

Second page of the Additive Wizard: For the build and the base, define mesh characteristics that determine mesh size.

Remember that the layer-by-layer additive printing process is simulated with element layers added one by one using the element birth technique. As such, the mesh must have a uniform size in the build (global Z) direction. That is, each element layer must have the same height (constant Z coordinate).

Options for the build allow you to specify either element size directly (in length units) or the number of layers. We recommend using one finite element “super layer” of Cartesian (brick) elements to represent 10-20 actual metal powder layers. If your machine has a 25-micron powder layer thickness (also called deposition thickness), your element size should be between 0.25 and .5 mm. The mesh must have a uniform size in the build (global Z) direction, that is, each element layer must have the same height (constant Z coordinate). The element sizing does not have to be an even multiple of the deposit layer thickness. Note that the real machine build time is approximately the transient thermal build step simulation time multiplied by $R^{(1/3)}$, where $R$ is the number of deposit layers in one element layer. (This estimate of the real build time is provided for you in the simulation results.)

For the base, specify element size directly (in length units). A much coarser mesh is acceptable for the base plate because it is simply serving as a heat sink and a fixed support in the simulation.

Regardless of whether your part rests on the base plate ($Z=0$) or if the part is elevated by supports, you must include contact elements on the surfaces where the bodies meet. This can be done automatically here.

Procedural Steps

1. Choose a mesh type, either Cartesian or Layered Tetrahedral. The Layered Tet mesh is not available if powder or supports are present. These scenarios should be set up outside of the Wizard if you want to use Layered Tet mesh.

   If Using a Cartesian Mesh:

   a. For the build (part and supports), specify mesh size by either inputting the Build Element Size (edge layer height) directly or by indicating the Number of Element Layers (i.e., superlayers) in the build.

   b. Enter a Projection Factor between 0 and 1. The Projection Factor defines how well the mesh will fit to the geometry. A value of 0 results in cubic elements with a rough fit to the geometry. Increasing the Projection Factor will change the shape of the elements to better fit the geometry and may yield better results in some cases but may also result in a failed mesh. Our recommendation is to set it to 0, or close to 0, initially. The default is 0. (Note that if you chose to have the application generate supports in the previous step, or if you indicated No Supports, you will not see the Projection Factor option as it is set to 0 automatically.)

   If Using a Layered Tetrahedral Mesh:

   a. For the build (part and supports), specify Layer Height. Note that the layer height should balance the need to capture features and the need for a reasonable simulation run time. The recommended setting for this "super layer" is 10-20 times the size of the machine deposition thickness.

   b. Specify Build Element Size. This can be slightly greater than Layer Height.
If you are not happy with the mesh resulting from this step, you may want to adjust the mesh parameters in the Details view of the Mesh object in the project tree. Also, see Using a Layered Tetrahedrons Mesh (p. ?) for more information about Layered Tet mesh controls.

2. For the base, specify **Base Element Size**.

3. Generate mesh now, Yes or No. By default, the mesh will be generated as soon as you hit Next on this page of the wizard (the Yes option). You have the option to delay mesh generation until later (the No option) if you suspect it will take a while.

4. Generate contact connections between the build and the base now, Yes or No. By default if you choose to mesh now, the contact connections will be generated as soon as you hit Next on this page of the wizard (the Yes option). You have the option to delay contact generation until later (the No option), in which case you will manually have to do this later in the project tree.

5. Click **Next**.

### 4.6. Generate Supports (Third Page of Additive Wizard)

**Third page of the Additive Wizard:** If you indicated that you want supports to be automatically created for you, it happens here. You need to specify an overhang angle (the default value is 45° to the horizontal X-Y plane) under which supports will be created or select individual element faces under which supports will be created. Supports are generated vertically straight down from the overhanging portion of the build to the base, or to a lower portion of the model if it is in the way.

**Procedural Steps**

---

**Note:**

If, in the first step of the wizard, you identified support bodies that were included in your CAD geometry, you will not be allowed to generate additional supports here and you will automatically be directed to the next step. The supports imported with CAD are considered Predefined Supports. Supports created in the Mechanical application are considered Generated Supports. The Wizard does not support the STL Support type but you will be able to generate or import supports later, if desired, using the interface.

1. Choose the scoping method, either Overhang Angle or Element Face Selection, to identify support regions under which supports will be generated.

   - If you choose to identify support regions by overhang angle, enter the **Overhang Angle**. Supports will be generated vertically downward under features with an angle of less than Overhang Angle to the horizontal X-Y plane. Defaults to 45°.

   - If you choose to identify support regions by element faces, click the **Mesh** object in the project tree to see the mesh and be sure to change the mode of selection to element face

     ![Selection modes](image)

     Use Ctrl-left-click to select multiple element faces, or double-click-left to select all the elements on the surface. Click **Apply**. Supports will be generated only under the element faces selected.
2. Click **Next**.

Supports are generated as *elements only* (i.e., there are no corresponding geometric bodies created for the new supports). When viewing geometry in the Geometry window you won't see the supports. You will see the support elements when you click the AM Process object (or one of its children), or the Mesh object. Or you can use the Show Mesh toggle button to reveal the mesh even when the Model object is active.

More importantly, if you would like to use the supports generated in Mechanical in your final print strategy, you'll need to convert the elements to geometric bodies for the .stl file required by the printer.

### 4.7. Assign Materials (Fourth Page of Additive Wizard)

**Go directly to procedural steps. (p. 19)**

Supports are printed with the same material as the part but as thin walled structures with less mass than the part. In the simulation we model the supports as an equivalent "homogenized" solid rather than as thin-walled structures. Regardless of whether the supports are predefined or automatically generated, you will need to scale down their properties to account for this homogenization technique. Affected properties are elastic modulus, shear modulus, density, and thermal conductivity. The ways to do this include:

- Specifying an overall multiplication factor. This factor is the ratio of the actual support area to the area of the solid area. For example an overall multiplier of 0.33 will adjust the properties of the supports to be a third of that of the part material.

- Specifying individual multiplication factors for each orthotropic direction of each material property.
• Specifying wall thickness (T) and spacing (L) for “block-type” supports, commonly output from support generation tools. In this method, we calculate the equivalent homogenization factor for you.

Typical block-type supports

Procedural Steps

Assign materials to the build and to the base plate. The ANSYS pre-defined materials from the AM library are automatically populated in the drop-down.

1. From the dropdown, choose the material for the build (part and supports).
2. From the dropdown, choose the material for the base plate.
3. Choose a method to scale down material properties under Support Material Adjustments; either None, Overall Factor, Property Specific Factors, or Block Support Dimensions. Enter the appropriate factors.
4. Click Next.
4.8. Define AM Process Settings and Sequence Steps (Fifth Page of Additive Wizard)

Go directly to procedural steps. (p. 22)

An additive process simulation can be performed using either the Inherent Strain method or a coupled thermal-structural simulation method. With the Inherent Strain method, strains are calculated not from material properties and thermal loads but from the use of a Strain Scaling Factor. A thermal-structural additive simulation is used by default in the wizard, as described next.

The AM process is accomplished through sequential steps as follows:

Minimally, there will always be a build step in both the thermal and structural portions of the simulation and usually there is a cooldown step. (The wizard assumes there is a cooldown step.) Additional steps may be added to the structural analysis to simulate heat treatment, and/or to account for the removal of supports and/or the build from the base plate, as shown here:

It is important to note that residual stress and distortion results may be affected by the order in which you remove supports. (The wizard specifies that all supports will be removed at once.)
Other steps may be added to simulate bolt pretension, clamps, unbolting the base plate, and other types of conditions but these advanced steps are not available in the wizard and need to be defined in the AM Process Sequencer. See Define AM Process Steps (p. 62) in the next chapter.

**Machine Settings** refer to process parameters which vary for each AM machine as well as for the material used in the deposition process. Inputs for machine settings are used to calculate the real, physical time duration of the build process so that the cooldown time can be determined.

**Build Conditions** are the settings pertaining to the environment in the build chamber around the part as it is being printed, including the preheat temperature. During a PBF print process, almost all the heat dissipation is conducted through the part back to the base plate rather than out through the unmelted powder surrounding the part. Many users ignore the small effect of heat loss through powder but you may choose to model it as equivalent heat convection.

**Cooldown Conditions** are the settings pertaining to the environment in the build chamber around the part in the cooldown step after the last layer is printed.
Procedural Steps
If Using the Inherent Strain Method

1. Set Inherent Strain to **Yes** from the dropdown. (No is the default.)

2. Machine settings may be input manually in the wizard or by loading a preset .xml file.
   - To enter build settings *manually*, enter values for Deposition Thickness and Strain Scaling Factor. Units are in the **solving units**.
     - Deposition Thickness: The thickness of added material; that is, the amount the base plate drops between layers.
     - Strain Scaling Factor: This is a calibration factor used to account for differences in machines, process parameters, and other variables. This value is a direct multiplier to the yield strain. Some material and geometry combinations result in bulging/expansion rather than shrinkage and so a negative SSF is possible. Values between -1 and 1 will reduce displacement and stress while values outside of that range will amplify them. Using a value of 0 will result in no strain and the final displacement will match the input geometry. The default value is 1.
   - To load a *preset file* of build settings, click **Edit** and browse to the file location and click **Open**. When you add a preset file, the wizard input fields become unavailable for edit. (An option to save a preset file is available in the Build Settings object in the project tree.)

3. Under **Removal Settings**:
   - Heat Treat - Choose **Yes** if you want to simulate heat treatment after the build and cooldown.
   - Base Removal - Choose **Instantaneous** if you want to remove the build (part and supports) from the base plate all at once. Choose **Progressive** if you want to specify a step size and direction for removal from the base plate.
     - Cut Step Size: Distance removed in each step of the simulation.
     - Cut Direction: Specifies the cutting direction (+X, -X, +Y, or -Y).
   - Support Removal - Choose **On** if you want to remove supports from the part. The supports will be removed all at once when set up through the wizard. (Removal of supports individually may be done through the interface.)

**Important:**

There is a known limitation at this release when all the following conditions exist:

- You are using the Additive Wizard, and
- You have chosen the Inherent Strain method (Inherent Strain = Yes), and
- You have chosen instantaneous base removal (Base Removal = Instantaneous)

Under the above conditions, you will not be able to finish the wizard. (The Finish button will be grayed out.) As a workaround, we recommend you set no base removal in the wizard (Base Removal = Off) and then set your removal options manually in the UI after
you close the wizard. See Define AM Process Steps (p. 62). You will need to prevent rigid body motion when the base is removed as described in Apply Structural Boundary Conditions (p. 70).

**Important:**

There is a known limitation at this release when all the following conditions exist:

- You are using the Additive Wizard, and
- You have chosen to Create Supports, and
- You have chosen progressive base removal (Base Removal = Progressive)

Under the above conditions, you will get an error when you solve the structural analysis that indicates "Build and Support" named selection not defined. The Build and Support named selection is normally generated automatically by the wizard.

The workaround is to create this named selection manually in the UI after you close the wizard. Select the **Named Selection** object in the project tree, right-click and **Insert > Named Selection**. Click the newly created **Selection** object, right-click **Rename** and then rename the object to **Build and Support**. Next you need to identify the build and generated support bodies. Select the part and the generated support elements (use the Body mode of selection and use the Ctrl key for multiple selections) and, in Details of the Build and Support object, click **Apply**.
If Using a Thermal-Structural AM Simulation (Inherent Strain = No)

1. Be sure Inherent Strain is set to No (default).

2. Machine settings may be input manually in the wizard or by loading a preset .xml file.
   - To enter build settings manually, enter values for all the items under Machine Settings, Build Conditions, and Cooldown Conditions. Units are in the solving units.

**Machine Settings**
- Deposition Thickness: The thickness of added material; that is, the amount the base plate drops between layers.
- Hatch Spacing: The spacing between adjacent scan lines when rastering back and forth with the laser.
- Scan Speed: The average speed at which the laser scans, excluding jump speeds and ramp-up and ramp-down speeds.
- Dwell Time: The span of time from the end of the laser scan of one layer to the start of the laser scan of the next layer. It includes the time required for recoater-blade repositioning and powder-layer spreading.
- Dwell Time Multiple: The dwell-time multiplier accounts for more than one part in the build. If they are the same part arranged in the same orientation on the build plate, the multiplier is the number of parts. If different parts exist on the plate, the multiplier is an estimate of the time required to build the other parts relative to the part being simulated.
- Number of Heat Sources: For multiple-beam printers, specifies the number of lasers.

**Build Conditions**
- Preheat Temperature: The starting temperature of the base plate.
- Gas/Powder Temperature: Temperature of the gas and the powder in the build chamber. You do not need to specify the same temperature for both.
- Gas Convection Coefficient: Convection coefficient from the part to the gas in the chamber. For the PBF process, the convection is applied only to the top of a newly deposited layer. (For a DED process, convection is also applied to the sides of the build.)
- Powder Convection Coefficient: Effective convection coefficient from the part to the powder bed. To estimate, divide the conduction property of the powder (KXX) by a characteristic conduction length into the powder (for example, a quarter of the distance from the part boundary to the build-chamber wall). Typically this is a very small value and is oftentimes ignored.
- Powder Property Factor: A knockdown factor used to estimate the powder properties. The Mechanical application applies the factor to the solid material properties to estimate the properties of the material in its powder state. The powder-state properties are used in the newly added layer during the heating of the new layer (before its subsequent solidification and cooldown) prior to the next layer being applied. The default value is 0.01.
**Cooldown Conditions**

- **Room Temperature**

- **Gas/Powder Temperature:** Temperature of the gas and the powder in the build chamber. You do not need to specify the same temperature for both.

- **Gas Convection Coefficient:** Convection coefficient from the part to the gas in the chamber. In this cooldown step, the convection is applied only to the top layer.

- **Powder Convection Coefficient:** Effective convection coefficient from the part to the powder bed. To estimate, divide the conduction property of the powder (KXX) by a characteristic conduction length into the powder (for example, a quarter of the distance from the part boundary to the build-chamber wall). Typically this is a very small value and is oftentimes ignored.

• To load a **preset file** of build settings, click **Edit** and browse to the file location and click **Open**. We provide generic sample files for our AM materials in the ANSYS Inc directory, for example: C:\Program Files\ANSYS Inc\v201\aisol\DesignSpace\DSPages\SampleData\AdditiveManufacturing. (The ANSYS directory on your machine may not be on the C drive.) The ANSYS-supplied sample files should be used for thermal-structural AM simulations only, since the Strain Scaling Factor is set to 1. When you add a preset file, the input fields for Machine Settings, Build Conditions, and Cooldown Conditions become unavailable for edit. (An option to **save** a preset file is available in the Build Settings object in the project tree.)
3. Under **Removal Settings**: 

- **Heat Treat** - Choose **Yes** if you want to simulate heat treatment after the build and cooldown.

- **Base Removal** - Choose **Instantaneous** if you want to remove the build (part and supports) from the base plate all at once. Choose **Progressive** if you want to specify a step size and direction for removal from the base plate.
  
  – **Cut Step Size**: Distance removed in each step of the simulation.
  
  – **Cut Direction**: Specifies the cutting direction (+X, -X, +Y, or -Y).

- **Support Removal** - Choose **On** if you want to remove supports from the part. The supports will be removed all at once when set up through the wizard. (Removal of supports individually may be done through the interface.)

**Important:**

There is a known limitation at this release when all the following conditions exist:

- You are using the Additive Wizard, and
- You have chosen to Create Supports, and
- You have chosen progressive base removal (Base Removal = Progressive)

Under the above conditions, you will get an error when you solve the structural analysis that indicates "Build and Support" named selection not defined. The Build and Support named selection is normally generated automatically by the wizard.

The workaround is to create this named selection manually in the UI after you close the wizard. Select the **Named Selection** object in the project tree, right-click and **Insert > Named Selection**. Click the newly created **Selection** object, right-click **Rename** and then rename the object to **Build and Support**. Next you need to identify the build and generated support bodies. Select the part and the generated support elements (use the Body mode of selection and use the Ctrl key for multiple selections) and, in Details of the Build and Support object, click **Apply**.

---

4.9. **Apply Boundary Conditions (Sixth Page of Additive Wizard)**

Apply boundary conditions to the base plate for both the thermal and structural portions of the simulation.

**Thermal Boundary Conditions**

In the AM Process Settings step of our workflow, we have already accounted for convection between the build and the gas in the chamber and convection between the build and the unmelted powder around the part – in both the Build Step and the Cooldown Step. There is one other area of heat transfer to consider and that is associated with the base plate.
During the build process, the plate is typically heated on the bottom to maintain a constant, slightly elevated temperature. You may insert a temperature constraint or convection surface to simulate this during the build step. If the plate is not heated, perhaps apply a room condition convection surface or set the surface boundary condition to adiabatic.

After the print process is complete, the base plate heating is removed and the built part cools to room temperature. This is simulated by a room-temperature convection surface applied to the bottom of the base plate in the cooldown step.

The time duration of the cooldown step is estimated based on the average part temperature at the end of the build, its volume, and material properties. Using the convection values and room temperature, the Mechanical application solves the simple heat transfer equation to get an estimate of the cool down time. It is only an estimate so you can extend it if required or put in a preferred time in analysis settings. One final step is done to force all the temperatures to room temperature for the subsequent distortion and stress calculation.

**Structural Boundary Conditions**

The base plate is anchored in place throughout the entire print process. This is accounted for in the simulation as a fixed support boundary condition on the bottom of the base plate in the structural analysis.

If a base removal step is included, you need to apply fixed boundary conditions to three nodes on the part to constrain it when the base is removed. This prevents rigid body motion.

**Procedural Steps**

**Base Thermal Boundary Conditions**

Use geometry selection (or a named component) to identify the bottom surface of the base plate upon which to apply thermal boundary conditions. Be sure your mode of selection is on Face.

1. Select the surface. Click **Apply**.
2. From the dropdown, choose Temperature, Convection, or Adiabatic for the boundary condition during the **build step**.
   - **Temperature** applies a constant temperature. This is often the same as the preheat temperature.
   - **Convection** requires a convection coefficient.
   - **Adiabatic** forces a condition of no heat transfer across the surface.
3. From the dropdown, choose Temperature, Convection, or Adiabatic for the boundary condition during the **cooldown step**.
   - **Temperature** applies a constant temperature. This is usually room temperature.
   - **Convection** requires a convection coefficient.
   - **Adiabatic** forces a condition of no heat transfer across the surface.
Base Structural Boundary Conditions

1. To apply a fixed support boundary condition for the structural analysis, select the same surface (the bottom of the base). Click Apply.

Heat Treatment Boundary Conditions

If you chose to add Heat Treatment in a previous step, you need to apply a convection to the build and baseplate bodies and specify the heat treat conditions.

1. First switch the mode of selection to Body. Select the build and the base bodies. Click Apply.
2. Enter the Temperature, in °C, for the Heat Treatment step.

Close the Wizard

1. Click Finish to complete the wizard.
2. Click the Open Wizard toggle button to close the wizard.

At this point you will continue the simulation in the Mechanical interface. It is a good idea to review the objects in the project tree that were created by the Additive Wizard. Notice the Named Selections for the build body, the base body, support bodies, contact connections, and constraint nodes. Mesh objects, boundary condition objects and others have been added or changed “behind the scenes” by the wizard. You can make changes or add items as needed. If no changes are necessary you are ready to proceed to the solution step.

4.10. Solve the Transient Thermal Analysis

Some users prefer to solve the thermal analysis first to observe how the simulation is progressing while others prefer to set up everything and run both the thermal and structural analyses at once. Either way is perfectly acceptable. To run them both at once, simply execute a solve from the static structural side and the transient thermal analysis will be run first automatically.

Since the solution can take significant time to complete, a solution status window is provided that indicates the overall progress of the solution. Other solution trackers and tools allow you to i) view the actual output from the solver, ii) graphically monitor items such as convergence criteria, and iii) view the temperature contour as the build progresses. You can also monitor some result items such as temperature at a node as the solution progresses.

1. To set up a plot of overall temperature that will be updated throughout the solution, under Transient Thermal, Solution, Solution Information, select Insert > Temperature Plot Tracker.
2. Right-click the Temperature plot tracker object and select Switch to Automatic Mode. This will show a live display as the solution progresses. Note that the plot tracker object must be selected in order to see the live display.
3. To initiate the solution, under Transient Thermal, highlight the Solution object, right-click and select Solve.

### 4.11. Solve the Static Structural Analysis

Watch live trackers plot the total deformation as the solution progresses.

1. To set up a plot of overall deformation that will be updated throughout the solution, under the Static Structural object, Solution Information, select Insert > Deformation Plot Tracker.

2. To initiate the solution, under Static Structural, highlight the Solution object, right-click and select Solve.

3. While the simulation is solving, right-click the Total Deformation plot tracker object and select Switch to Automatic Mode. This will show a live display as the solution progresses.

### 4.12. Review Results

Once a solution is available you can contour the results or animate the results. You will have solutions at many time points and you can display the variation of the result item at a location over the build history.

A significant concern in additive manufacturing is whether the build will print successfully without experiencing blade interference (sometimes called blade crash). This phenomenon occurs when the powder recoater blade hits into a portion of the built part that has deformed extensively because of residual stresses. Usually the result is a stopped process and a failed build. You can check for this in the simulation by viewing an animation of the deformation in the Z direction and comparing to your threshold limit, such as double the deposition thickness.

At times you may want to obtain results along an edge or other specific location of the part to determine if the part will be within tolerances or to compare to distortion measurements made after the part is built. There are several ways to do this.

Finally, an estimate of the real 3D printing time is available in the solution as well.

### Procedural Steps

Recall that you used Output Controls under Analysis Options to control which items are solved for in the simulation. You also may have set up results trackers in the solution step to observe the results being processed during the solution. When reviewing results after the solution, you will generally need to evaluate results to obtain them for viewing. Evaluating results is a way to retrieve them from the data that was stored during solution. Only data items that were solved for may be retrieved in this way.

There are many different ways to view results but some of the ones most commonly used for additive manufacturing are described here:
Animate Thermal Results - Temperatures

1. In the project tree under Transient Thermal, select the Solution object and then, in the context menu, click Thermal and then Temperature. Or right-click Insert > Thermal > Temperature. A Temperature object is created and becomes active.

2. Right-click Temperature and select Evaluate All Results. This retrieves the temperature data and displays it in both graph and tabular form.

3. Use the animation controls at the top of the Graph window. Click the Result Sets button and also the Update Contour Range at Each Animation Frame button. Adjust the number of seconds for the animation and click Play. See Animation in the Mechanical User's Guide for more information about animation controls.
**Animate Structural Results - Total Deformation**

1. In the project tree under Static Structural, select the **Solution** object and then, in the context menu, click **Deformation** and then **Total**. A Total Deformation object is created and becomes active.

2. Right-click **Total Deformation** and select **Evaluate All Results**. This retrieves the deformation data and displays it in both graph and tabular form.

3. Use the animation controls at the top of the Graph window.

4. It is important (and fun!) to change the magnification scale of the display in the Geometry window so you can get a true sense (or an exaggerated sense) of the deformation in your build. With Total Deformation highlighted in the project tree, from the **Result** context tab, select the **True Scale** option from the drop-down menu. Animate the results using the animation controls. Select other scales from the drop-down menu to see exaggerated results.

The following is an animated GIF. Refresh the page to see the animation. View online if you are reading the PDF version of the help.
Check for Blade Crash

Note:

At this release, a **Blade Interference Tool** is available as a Beta feature. It will predict where blade interference will occur during the build process. Use the Blade Interference Tool in lieu of the procedure described next.

1. Right-click the **Directional Deformation** object and select **Evaluate All Results**.

2. In the legend area of the Geometry window, double-click the lower limit of the uppermost color bar (red) to insert your own number. Enter a number that represents a threshold limit for blade interference. Consider using twice the deposition thickness. Rotate your model so you can see a top-down view and then animate the Directional Deformation results. If you see red contours, those are locations of concern for blade crash. Note that the image below does not show deformation above the threshold on the top layer, which is the layer of concern for blade interference. (Rotating the model for a top-down view, which we did not do in this figure, makes it easier to view the top layer.)
Scope a Line of Nodes to Get Results in Specific Locations

Suppose you want to obtain X-direction deformation along a line on a face of your part, such as shown below, at the end of the cooldown step.

There are several ways to perform this function but we will demonstrate it using a Worksheet. To obtain distortion results along a line on the surface of your part:

1. Create a Named Selection: Highlight the Model object, right-click and select Insert > Named Selection. Right-click the newly created Selection object (under Named Selections) and Rename to something meaningful, for example, Line of Nodes.
Get an Estimate of the Actual 3D Printing Time

View the solver output to get an estimate of the real machine build time. It is approximately the transient thermal build step simulation time multiplied by \( R^{1/3} \), where \( R \) is the number of deposit layers in one element layer. This data is available after the thermal solution. Click **Solution Information** and then click the **Worksheet** tab under the Geometry window.

![Worksheet](image)
Chapter 5: AM Process Simulation Workflow - Without the Additive Wizard

An AM Process Simulation involves most of the general steps found in any ANSYS analysis with some additional steps and considerations as described in the following steps:

5.1. Create the Analysis System
5.2. Define Engineering Data
5.3. Attach Geometry and Launch Mechanical
5.4. Identify Geometry
5.5. Assign Materials
5.6. Apply Mesh Controls and Generate Mesh
5.7. Identify and/or Generate Supports
5.8. Define Connections
5.9. Define AM Process Steps
5.10. Define Build Settings
5.11. Establish Thermal Analysis Settings
5.12. Apply Thermal Boundary Conditions
5.13. Solve the Transient Thermal Analysis
5.14. Establish Structural Analysis Settings
5.15. Apply Structural Boundary Conditions
5.16. Solve the Static Structural Analysis
5.17. Review Results

5.1. Create the Analysis System

An AM Process Simulation requires a linked transient thermal analysis followed by a static structural analysis. For simplification, we assume the physics are uncoupled in that data flows one-way from the thermal analysis to the structural.

Procedural Steps

1. From the Analysis Systems folder, drag the Transient Thermal object onto the placeholder in the upper left corner of the Project Schematic.

2. Next, drag the Static Structural object over the top of the Transient Thermal object, and release the mouse when the cursor is on the Solution cell. The result is a linked system as shown here.
5.2. Define Engineering Data

The simulation requires a material with a melting temperature specifically defined. We recommend using temperature-dependent properties covering the range from room temperature to melt temperature. For the thermal analysis, the properties required are thermal conductivity, density, and specific heat. For the structural analysis we require Young's Modulus, Poisson’s Ratio, coefficient of thermal expansion, and a plasticity model, such as bilinear isotropic hardening. The following popular materials for AM are provided as samples in the ANSYS Additive Materials library:

- 17-4PH Stainless Steel
- 316 Stainless Steel
- AlSi10Mg Aluminium alloy
- Inconel 625
- Inconel 718
- Ti-6Al-4V Titanium alloy

For general information on how to include custom materials, see Material Data. A nominal strength should be provided at the melt temperature, as a near zero modulus and/or yield strength could lead to convergence problems. (ANSYS pre-defined materials take care of this internally.)

Procedural Steps

The part that you specify as the build geometry in Mechanical must refer to a material in Engineering Data that contains a definition for melting temperature. To access materials in Workbench:

1. Open the Engineering Data workspace by double-clicking on the Engineering Data cell of the Transient Thermal analysis. You can also select the cell, right-click, and select Edit.

2. In the Engineering Data workspace, select the Engineering Data Sources button above the Outline of Schematic pane.

3. Select the Additive Manufacturing Materials library in the Engineering Data Sources pane. This library lists a number of popular materials used for the PBF process. You need to include at least one supported
material to be assigned to the geometry you will use as the build geometry in Mechanical or create your own material.

4. Select the **plus icon** beside your desired material to make it available in Mechanical.

5. Return to the **Project** tab.

5.3. **Attach Geometry and Launch Mechanical**

Go directly to procedural steps. (p. 40)

Typically, you’ll have these geometric bodies in the simulation model:

- **Part** – This is the part you are manufacturing. It should be a closed volume (i.e., watertight), and should be oriented with the global Z axis as the build direction. It may be modeled either resting on the base plate (Z=0), or elevated off the base plate by supports. Usually only one part is simulated even if there will be many duplicate parts nested on the base plate for efficiency. (A multiplier on the build time should be used if this is the case, as described in Machine Settings (p. 62).) The part can be made of multiple bodies but must have boundaries that are aware of each other in order to assure a proper mesh throughout the part. This is achieved through either shared topology or contact connections, depending on your meshing approach, as you will learn later.

- **Support Structures** – Supports are needed to anchor overhanging part features so they do not break away from the platform during the 3D print process because of residual stress buildup. Overhanging features are usually those with angles less than 45° to the horizontal X-Y plane. Supports may be modeled in several ways. **Together, the part and supports constitute the build.**

- **Base Plate** – This is the platform on which the build (part plus supports) is to be printed. It is included in the simulation because it acts as a heat sink.
Other geometric bodies that may be simulated include:

- **Powder** – Modeling the powder may be useful if you will be simulating multiple parts close together on the build plate or if the part has features close together, where accounting for the heat transfer occurring between the parts or features is important. Create a separate, closed-volume (watertight) body to represent the powder in-between multiple parts or in-between features of the same part. Details of how to model powder (p. 97) in the simulation are found in Advanced Topics.

- **Non-build Components** – At times you may want to simulate geometry items that are present on the build plate but that are not being 3D-printed. These items may include clamps, bolts, measuring devices, instrumentation, etc. They may influence the heat dissipation and/or distortion of the part being built so they need to be included in the simulation. Details of how to model non-build components (p. 99) are found in Advanced Topics.

For your part geometry, commonly imported file types include SpaceClaim .scdoc files (non-faceted) and stereolithography .stl files (faceted). See Attach Geometry/Mesh in the Mechanical User’s Guide for other options.

You may create the base plate and supports ahead of time in the CAD program or in a support generation tool, or wait to create those bodies in the Mechanical application (described in subsequent steps). Note that if supports are created in CAD, the part and support bodies should be kept as separate bodies (i.e., not merged) so that they can be distinguished as such in the AM simulation in Mechanical. Whether you set the bodies to "share topology" in the CAD program depends on whether you will be using a Cartesian mesh or a Layered Tetrahedrons mesh in the simulation in Mechanical. See To Share Topology or Not? (p. 7) for a discussion about this topic. When everything is imported into Workbench, you will later identify the support bodies as predefined supports.

Alternatively, you may choose to not include supports when you attach the part but import the supports separately later as .stl files.

**Procedural Steps**

1. Right-click the Geometry cell of the Transient Thermal analysis block, and select Import. Browse for your file and import it. (Double-clicking on the Geometry cell opens SpaceClaim.)

2. After importing geometry, double-click the Model cell (or right-click, and select Edit) of the Transient Thermal analysis block to launch the Mechanical application. It may take a few minutes for Mechanical to open and your geometry to appear in the Geometry window.

3. Once your geometry is loaded in Mechanical, review how it is presented in the project tree. We will use an example model to be simulated that includes an arch part and a solid support as separate bodies comprising the build, and the base plate as another separate body.

Recall that there are different requirements for connectedness of geometric bodies depending on the mesh method you will be using; a Cartesian mesh method requires shared topology whereas a Layered Tetrahedrons mesh method requires that there be no shared topology (i.e., unshared topology).

To check whether your geometry has shared topology, click the Display tab and in the Edge group, choose Color and then choose By Connection from the drop-down menu. Pink edges means that an edge is shared by three faces which is an indication of shared topology.

In the arch with support example, the geometry in the first figure was imported from SpaceClaim with shared topology. First notice the structure of the bodies in the project tree. The arch part and support bodies are child objects under Build. Also, in the Graphics Window, note the pink edges at...
the body interfaces when Edge Coloring > By Connection is turned on. We will mesh this model with a Cartesian mesh method.

![Image of a model with shared topology](image1)

The geometry in the next figure was imported from SpaceClaim with unshared topology. Notice how the bodies are shown as independent bodies in the project tree, not as child objects under the Build object. Also, there are no shared edges between bodies (lines are black instead of pink), indicating there is no shared topology. We will mesh this model with a Layered Tetrahedrons mesh method.

![Image of a model with no shared topology](image2)

4. Once the Mechanical application opens, it is a good time to adjust the number of processors (cores) you are using on your computer. Depending on the complexity of your model, AM Process Simulations may be computer intensive. If you have an ANSYS HPC license, access the option in the Solve group on the Home tab and change the Cores to something appropriate for your simulation.
5.4. Identify Geometry

On the imported geometry, identify which bodies are associated with the build (part and supports, if any) and the base plate. If your geometry from CAD does not include a base plate, use the Construction Geometry feature to create one.

Procedural Steps

To establish the options and assumptions appropriate for an additive manufacturing simulation, you need to insert the AM Process object into the project tree. Note that the AM Process object is available only if you have an ANSYS Additive Suite software license with ANSYS Mechanical Enterprise or one of the multiphysics bundles. If AM Process is grayed out, check your software license.

1. Select the Model object in the project tree, then select the Model contextual tab on the ribbon and then the AM Process option in the Define group. Or, right-click the Model object or in the Geometry window and select Insert > AM Process.

Once you insert the AM Process object, certain automatic actions take place. The application automatically:

- Displays the AM Process context tab, providing useful shortcut options specific to an AM Process Simulation. These will be demonstrated in subsequent steps.

- Sets Step Controls in an AM Process Sequence worksheet (discussed later) and in Analysis Settings for each analysis.

- Suppresses the calculation of thermal fluxes, nodal forces, Euler angles, volume and energy, and other miscellaneous items to reduce the size of the result file. (Set in Analysis Settings for the transient thermal analysis.)

2. Next you need to identify which bodies are which in the geometry you imported. Select the AM Process object and then:

- Select the body or bodies representing the part and all the supports that make up the Build Geometry and hit Apply in the Details view. To select a body, be sure that your mode of selection is on body (rather than on face, edge, or vertex). Use the Ctrl key while clicking the left mouse button to select multiple entities (or click, hold, and drag). Or use Named Selections as a basis for selection. The build is now shown in red. (If you want to have the application create supports automatically, you'll do that later.)

- Select the body that is the Base Plate Geometry and hit Apply in the Details view. The base is now shown in blue. (If your imported geometry does not have a base plate, construct one using step 3.)
At the bottom of the Details view, the offset of the part from the base is shown as Z Location at Top of Base. This is simply a confirmation of what the Mechanical application reads from the CAD file.

3. To create the base plate if not imported with the CAD geometry, select the **Model** object and then:

   - Select the **Construction Geometry** option in the Prepare group on the Model context tab. Or right-click the **Model** object or in the Geometry window and select **Insert > Construction Geometry**.

   - Right-click the new **Construction Geometry** object (under Model) and choose **Insert > Solid**.

   - In the Details panel, fields appear for you to enter overall dimensions of the base and coordinates for the center of the top of the base. Enter values for X1, X2, Y1, Y2, Z1 and Z2. An outline is provided to preview the dimensions. Right-click on **Solid** and select **Add to Geometry**. See **Specifying Construction Geometry** for more information.

   - To identify this newly created body as the Base Plate Geometry, highlight the **AM Process** object, select the new body and hit **Apply** in the Details view for Base Plate Geometry.

### 5.5. Assign Materials

Assign a material to each geometry body:

- All bodies comprising the build (part and supports) must be the same material.

- If you are modeling powder, use the same material as the build.

- Non-build components can be different materials.

- The base plate can be a different material.
**Procedural Steps**

When you select a geometry entity in the project tree, the Details view lists all the settings associated with that body.

1. In the project tree under Model, expand the **Geometry** object to see its child objects below it. Select the geometric entity that is the *build geometry* and, in Details view, change the **Assignment** (under Material) to be the appropriate AM material that you defined in Engineering Data. (The build material must have melting temperature defined.) When you assign a material to the build, the child objects below it, that is, the part and supports, if any, are also assigned that same material.

2. Select the entity that is the *base plate body* and change its material **Assignment**, as desired.

---

### 5.6. Apply Mesh Controls and Generate Mesh

Go directly to procedural steps. (p. 45)

The layer-by-layer additive printing process is simulated with element layers added one by one using the element birth/death technique. As such, the mesh must have a uniform size in the build (global Z) direction. That is, each element layer must have the same height (constant Z coordinate).

We recommend using one finite element “super layer” of elements to represent 10-20 actual metal powder layers. If your machine has a 25-micron powder layer thickness (also called deposition thickness), your element size should be between 0.25 and .5 mm. The element sizing does *not* have to be an even multiple of the deposit layer thickness. Note that the real machine build time is approximately the transient thermal build step simulation time multiplied by \( R^{1/3} \), where \( R \) is the number of deposit layers in one element layer. (This estimate of the real build time is provided for you in the simulation results.)

Two primary meshing methods are available for additive manufacturing process simulation, each with their strengths and weaknesses.

- **The Cartesian Mesher** creates a voxel mesh that approximates the geometry. Small features, curved surfaces, and horizontal or vertical surfaces that are not multiples of the mesh size are not captured accurately unless a small mesh size is used. The method is fast and, for most distortion and residual stress predictions, is quite adequate.

  The Mechanical application can automatically generate supports when a part has a Cartesian mesh. (See **Generated Supports** (p. ?) in the next step.)

- **The Layered Tetrahedrons Mesher** creates a tetrahedron mesh that conforms to a specified layer size. It captures the geometry well, and is useful if there are organic curves, small features, such as holes, or for thin-walled parts. Care must be taken to ensure that the layer slices cut the geometry in such a way as to avoid thin slices. Thin slices may cause the mesher to struggle or result in poorly shaped elements. Usually adjusting the mesh layer size or increasing relative tolerance will lead to a higher quality mesh.

  The Mechanical application *cannot* automatically generate supports when a part has a layered tetrahedrons mesh, only Predefined Supports or STL Supports can be used. (See **Identify and/or Generate Supports** (p. 51).)

A much coarser mesh is acceptable for the base plate because it is simply serving as a heat sink and a fixed support in the simulation.
Procedural Steps

We will describe the meshing steps using the arch with support model for both the Cartesian and Layered Tetrahedrons mesh techniques.
Using a Cartesian Mesh

1. First, set mesh controls for the part and support bodies. The size of the mesh is required to be the same throughout all bodies in the build. Remember that the build requires a finer mesh than the base plate.

   a. To set mesh controls for the build, we will use a meshing shortcut designed for AM Process Simulations. In the project tree, select the AM Process object and then select the Cartesian Control option from the ribbon (AM Process context tab). Or, right-click the AM Process object and select Insert > Cartesian Mesh. Notice that a Body Fitted Cartesian object has appeared under the AM Process object and become active and that all the bodies that are part of the build are selected.

   b. In Details of the Body Fitted Cartesian object, under Definition, set the Element Size to the desired value. (Click in the right column on the word Default to activate the text field.)

   c. Under Advanced, set the Projection Factor slider to a value between 0 and 1. The Projection Factor defines how well the mesh will fit to the geometry. A value of 0 results in cubic elements with a rough fit to the geometry. Increasing the Projection Factor will change the shape of the elements to better fit the geometry and may yield better results in some cases but may also result in a failed mesh. Our recommendation is to set it to 0, or close to 0, initially and then iterate from there to see the effects of changing Projection Factor.

   **Note:**

   If you will be using Mechanical to generate supports, the Projection Factor must be set to 0.

You can apply a Coordinate System for the mesh. Typically, the default global coordinate system is appropriate but you may want to set it to one located on the top surface of the base plate.


2. Next, set mesh controls for the base plate. Highlight the Mesh object and right-click Insert > Sizing. A Sizing object is created under the Mesh object and becomes active.

   a. Select the base plate body and hit Apply in the Details view.

   b. Under Definition, change the Element Size to the desired value, something that will result in a fairly coarse mesh.

3. Finally, highlight the Mesh object and right-click Generate Mesh. If you don’t like the generated mesh you can easily go back and change element sizes, then right-click Mesh and select Update.
Cartesian mesh
Element Size = 0.5
Projection Factor = 0.75
Using a Layered Tetrahedrons Mesh

**Important:**

The mesh generated using the Layered Tetrahedrons method is not fully associated to the geometry. To have the mesh associated to the geometry, define Named Selections on the faces on which association is required *before meshing*, as described in the first two steps below.

To use a layered tetrahedrons mesh, in ANSYS Mechanical:

1. Under Connections, right-click **Contacts** and select **Create Automatic Connections**. This will create child objects under Contacts called Contact Region, Contact Region 2, Contact Region 3, etc. for all the surfaces near each other within a certain tolerance.

2. Select all the newly created contact regions, right-click and select **Promote to Named Selection**. This will create Named Selections of contact and target surface pairs as shown here. Now the connections have been set up so that you are ready to generate a mesh.

3. Click **Mesh** in the Tree Outline, right-click and select **Insert > Method**. Select the build geometry—use the Ctrl key to select multiple bodies, for example if you have support bodies—and...
in Details view, click **Apply**. In Details under Definition, change the **Method** to **Layered Tetrahedrons**.

**Limitations:**

- Bodies with shared topology are not supported. We recommend you separate them into individual parts in CAD (Use **Unshare** in SpaceClaim or **Explode Part** in Design-Modeler to do this.)
- Auto-generated supports are not available for parts meshed with layered tets. You should bring supports in with your geometry or as a separate .stl file.
- The model should not have other suppressed bodies.
- The mesh is not associated back to geometry.
- This method cannot be used in conjunction with mesh controls such as Inflation, Refinement, Match Control, Pinch, Face Meshing, Face Sizing, and Edge Sizing controls.

4. In the **Layered Tetrahedrons** Details view:
   a. Set the **Layer Height** as desired. Note that the layer height should balance the need to capture features and the need for a reasonable simulation run time. The recommended setting for this “super layer” is 10-20 times the size of the machine deposition thickness.
   b. Make sure the **Layer Start** (global Z axis value) refers to the top of the base plate (bottom of the build).

   Most of the remaining advanced settings in the Details view have adequate defaults.
5. Click the Mesh object, and in its Details view, change the following global settings:
   
a. Set the **Element Order** to **Quadratic**. Note that mid-noded elements will be generated, but the mid-nodes will be kept straight and will not conform to the geometry.

b. Set **Use Adaptive Sizing** to **No**. (Max Size does not influence the layered tet meshing.)

c. Set **Capture Curvature** to **Yes**. Set an appropriate value for the **Curvature Min Size**. The Curvature Min Size is used by the meshing to generate a surface mesh before the slice layers are generated, hence this min size drives the resolution of the mesh. The minimum size should be decided based on the features which are to be resolved and the Layer Height. The default value for the Curvature Min Size might not be ideal as this value is usually very small compared to the size of the geometry. A recommended value is 1/4 to 1/3 of the Layer Height. The recommended range for the **Curvature Normal Angle** is 18 to 36 degrees. Use a lower angle if the model has small features like holes, fillets etc. that you want to preserve.

d. Specify **Element Size**, which can be greater than Layer Height. The Element Size should not be greater than 6 times the Curvature Min Size specified. The mesh quality reduces as the Element Size / Curvature Min Size ratio increases.

e. Set the **Growth Rate** if desired. The default 1.85 is adequate, with the recommended range of values between 1.2 and 2.

f. **Defeature Size** is used to define the default value for sliver face height. The recommended value to start with is 10% of the Curvature Min Size. Based on the model, you might be required to increase it. We do not recommend using a value greater than one half of the Curvature Min Size.

6. Back in the Layered Tetrahedrons Details view, you may want to consider the following advanced settings if you are not happy with the tetrahedrons mesh after first generation:

   a. **Relative Tolerance**: Nodes within the given tolerance value to the slice plane will be projected to the slice plane during the initial slicing operation. The default value is 0.01 (1%) which can be used for most cases. The recommended range of values is 0.01 to 0.02 (1-2%). For extreme cases, you may use a value of up to 0.05.

   b. **Inflate Relative Tolerance**: This relative tolerance is used to improve the surface mesh in the thin layer regions after the slicing operation is done. This tolerance is used to move (inflate) nodes away to the value specified to improve the quality. The default is 0.1 i.e 10% (of the size in region of concern). You usually get good results when this tolerance is in the range of 0.1 to 0.3. The largest acceptable value for this setting is 0.5, which should be used very carefully.

   c. **Sliver Triangle Height**: Problematic sliver faces are identified based on Sliver Triangle Height and are collapsed or fixed to improve quality. The Sliver Triangle Height is based on the Curvature Min Size specified. The default value is 10% of this minimum size. Based on the model, you may need to increase the value, however, the value should not be greater than 50% of the min size.
7. Next, set mesh controls for the base plate that will produce a much coarser mesh. Highlight the Mesh object and right-click **Insert > Sizing**. A Sizing object is created under the Mesh object and becomes active.

   a. Select the base plate body and hit **Apply** in the Details view.
   
   b. Under Definition, change the **Element Size** to the desired value, something that will result in a fairly coarse mesh.

8. Finally, highlight the Mesh object and right-click **Generate Mesh**. If you don’t like the generated mesh you can easily go back and change element sizes and settings, then right-click Mesh and select Update.

Understanding the approach that the Layered Tetrahedrons mesher uses may be useful if you are not satisfied with the meshes being generated. Refer to **Layered Tetrahedrons Method Control in the Meshing User’s Guide** for further information.

---

**5.7. Identify and/or Generate Supports**

Go directly to procedural steps. (p. 53)

Recall that supports may be imported with your geometry, you may create them in Mechanical, or you may import them as a separate .stl file, or some combination of the three.

- **Predefined Supports** are supports that are imported with your geometry and you will need to identify them as such.
• **Generated Supports** are available only for parts meshed with Cartesian mesh. These supports generated by the Mechanical application are either automatically detected or user-defined. For automatic detection you specify an overhang angle (the default value is 45° to the horizontal X-Y plane) under which supports will be created. For user-defined supports you select individual element faces under which supports will be created. Supports are generated as elements vertically straight down from the overhanging portion of the build to the base, or to a lower portion of the model if it is in the way.

• **STL Supports** are supports imported as .stl files and are generally volumeless (i.e., not watertight), thin-walled structures created with Additive Prep or other support-creation tools.

**We Treat Supports as Homogenized Solids**

In additive machines, supports are printed with the same material as the part but as thin walled structures with less mass than the part. In the simulation we model the supports as an equivalent "homogenized" solid rather than as thin-walled structures. Regardless of whether the supports are predefined, automatically generated, or imported as .stl files, their properties will be scaled down to account for this homogenization technique. Affected properties are elastic modulus, shear modulus, density, and thermal conductivity.

Scaling down properties is done automatically for STL Supports. For Predefined and Generated Supports, you will do this in one of three ways:

• Specifying an overall multiplication factor. This factor is the ratio of the actual support area to the area of the solid area. For example an overall multiplier of 0.33 will adjust the properties of the supports to be a third of that of the part material.

• Specifying individual multiplication factors for each orthotropic direction of each material property.

• Specifying wall thickness (T) and spacing (L) for "block-type" supports, commonly output from support generation tools. In this method, we calculate the equivalent homogenization factor for you.
**Typical block-type supports**

Equivalent “homogenized” strength

**Procedural Steps**

Supports are identified and/or added using the Supports group in the AM Process context menu. As you add supports, objects are added to the project tree under AM Process. You may want to rename these objects to meaningful names if you have many support groups. If things get confusing as you add supports, useful tools are the Hide Support and Hide All Other Bodies options, accessible by right-clicking on any support object.
**Predefined Supports**

If support bodies were included in the CAD geometry, you need to identify them as supports so that the Mechanical application is aware of which bodies to adjust properties for, or to remove if support removal steps are specified. To identify these predefined supports:

1. Highlight the **AM Process** object, and then select the **Predefined Support** option on the AM Process context toolbar. Or right-click in the Geometry window and select **Insert > Predefined Support**.

2. Select the support bodies (geometry selection) with the mouse, holding the Ctrl key down to select multiple bodies (or click, hold, and drag). Click **Apply**. Or, choose Named Selections.

3. To scale down material properties, in Details under Support Material Settings, choose **Block** or **User Defined** for Support Type. If choosing Block supports, specify Wall Thickness (T) and Wall Spacing (L). If you choose User-Defined for Support Type, you may adjust the material properties by specifying either one overall multiplier or property-by-property multipliers. These multipliers are the ratio of geometric areas of the supports to the areas of the solid geometry, where the areas are the projected areas in the X, Y, and Z directions.
Generated Supports

The Mechanical application's ability to automatically generate supports is available only if the part is meshed with a Cartesian mesh. When generating supports, the application can automatically determine their locations or you can specify the support locations.

For automatic detection:

1. Highlight the AM Process object, and then select the Generated Support option on the context toolbar. Or right-click in the Geometry window and select Insert > Generated Support.

2. Click the Support Group object above Generated Support and change the overhang angle, Hang Angle, to an angle between 0 and 90°, or leave it at the default of 45°.

3. Right-click Support Group and select Detect and Generate Supports. Supports are generated for all bodies that are part of the build. Note that an option exists to Detect Supports only (i.e., not generate supports). This is quite useful if you want to see the effect of changing Overhang Angle. If you are satisfied with the location of supports, then select Generate Support Bodies. Another option allows you to detect and generate supports above a particular Z location (Detect above Z location, in Details of Support Group), allowing further control of where supports are generated.

For user-defined generated supports, you restrict the regions under which supports will be generated by selecting specific element faces in Scoping Method:

1. Highlight the AM Process object, and then select the Generated Support option on the context toolbar. Or right-click in the Geometry window and select Insert > Generated Support.

2. Switch to element face mode of selection and use Ctrl-left-click to select multiple element faces, or double-click-left to select all the elements on a surface. Click Apply in the Details panel.

3. Right-click Generated Support and click Generate Support Bodies.

**Important:**

Supports are generated as elements only (i.e., there are no corresponding geometric bodies created for the new supports). When viewing geometry in the Geometry window you won't see the supports. You will see the support elements when you select the AM Process object (or one of its children), or the Mesh object. Or you can use the Show Mesh toggle button to reveal the mesh even when the Model object is active.

More importantly, if you would like to use the supports generated in Mechanical in your final print strategy, you'll need to convert the elements to geometric bodies for the .stl file required by the printer.
**STL Supports**

Inserting STL Supports enables you to import and mesh a support structure that is an STL file. This feature is designed primarily for inserting volumeless (i.e., non-watertight) supports such as those created by Additive Prep. The thin, intricate support walls that may include perforations are made of many small facets. We use a voxelizing technique, similar to that used in Additive Print, to account for this. The mesh is generated with cubic elements that are internally divided into subdivisions for sampling the presence of material to determine the overall densities of the elements. These, in turn, are used for the material knockdown factors.

Element size is set by the mesh criteria used for the part. It is for this reason that you must mesh the part before inserting an STL Support. If you used a Cartesian mesh, the element size uses the value you specified for Build Element Size. (Element size may be slightly smaller than the Build Element Size in certain cases.) If you used a layered tet mesh for the part, the element size will be the value you specified for Layer Height.

To import and mesh STL Supports:

1. Before inserting the STL Support, be sure the part is meshed and the build geometry is identified in the AM Process object. Highlight the AM Process object, and then select the STL Support option on the context toolbar. Or right-click in the Geometry window and select Insert > STL Support.

2. In the Details view of STL Support, identify the source of the STL file, either a file (default) or a previously imported STL Construction Object. Click File Name to navigate to the appropriate folder and select your STL support file.

3. Change the Length Units, as needed. The default is millimeters. Most often, this is what you want.

4. Identify the STL Support Type by selecting Volumeless or Solid from the drop-down. Volumeless (default) is for non-watertight supports such as block, heartcell, rod, or line supports created by Additive Prep. Most often, this is what you want. Choose Solid for solid bodies that are watertight, such as custom supports created in Additive Prep.

5. For Volumeless support type, adjust the Wall Thickness, as needed, according to the single-bead thickness set by your machine.

6. Adjust the Subsample Rate, as needed. For most cases, we recommend using the default value of 5.

The following figure shows a curved bar model with tree supports generated in Additive Prep imported as an STL Support.
The support structure will be meshed with cubic elements. Each cubic element is divided into sampling regions to determine density of support material within that element. These are used as material property knockdown factors. A Subsample Rate of 5 (default) = 5 x 5 x 5 = 125 subdivisions. Subsample Rate affects the accuracy of element density.

7. Right-click the **STL Support** object and select **Generate Mesh** to mesh the support.
8. Use the **Support View** (under Display) to switch back and forth among the view options of STL View, Mesh View, or Knockdown Factors. (Or, the knockdown factors may be turned on using Display Style in the Mesh object Details view.)

**Hint**: Look for the tiny icon to the left of an object in the project tree for a clue about its status. For example, if you see a question mark next to an STL Support object, it means you have not identified a file name yet. If you see a yellow lightening bolt, it means you have not generated the mesh for it yet. You will see a green check-mark once you have performed both of those tasks.

### 5.8. Define Connections

Connections are the mechanism to ensure that part and support bodies in the simulation are aware of each other and are able to share data (temperatures and displacements) across boundaries.

There are different approaches to defining connections, depending on your mesh and support scenario. The Mechanical application provides various tools to automate the creation of contact connections, as described in the procedures below.

**Procedural Steps**

Defining connections between part and supports should be performed after all bodies are meshed. For all scenarios, you will need to define a connection between the build and the base plate so we will start there.

Highlight the **AM Process** object and then select the **Create Base to Build Contact** option on the context toolbar.
Several things happen. You will see the contact body (red) and target body (blue) views shown in side windows of the Geometry window. The Contact Side is defined as the element faces of the bottom of the build (part and supports). The Target Side is defined as the element faces of the top of the base plate. In the project tree, a Contacts object is added under Connections with a Build to Base object underneath it. Also, Named Selections have been created that select the element faces at the build-base interface (Build Contact Element Faces and Base Contact Element Faces).

To define connections between the part and supports, choose from the appropriate scenarios described next. If you have no supports, skip ahead to the Establish Thermal Analysis Settings (p. 67) step.

If You Have a Cartesian Mesh

If you have meshed your part with a Cartesian mesh and are using predefined supports with shared topology, or have used only generated supports, you do not need to do anything else.

Skip ahead to the Establish Thermal Analysis Settings (p. 67) step.

If You Have a Layered Tet Mesh and Predefined Supports

If you have meshed both your part and predefined supports with layered tet mesh, we recommend you use beam element contact connections at the interfaces between the part and supports for a more robust solution.

Under Connections, Contacts, highlight the contact pair that represents the interface of the supports and the part, such as Contact Region 3. In Details view under Advanced:

- Change the Formulation to Beam
- Change the Material to match your build material
- Change the Radius to 10% of the Element Size used in the mesh (p. ?)

Do this for all the interfaces between the part and supports.
**If You Have a Layered Tet Mesh and STL Supports**

If you have meshed your part with a layered tet mesh and then you imported STL Supports, which are meshed with voxels, you now have dissimilar element shapes that must be connected. Dissimilar element shapes between part and supports present a challenge in an additive simulation, particularly STL Supports that may have holes within its structure. Simulations may produce unexpectedly high or low temperature, excessive displacement, or even divergence of the solution. We recommend using an APDL command macro called AMCONNECT that creates constraint equations between the support nodes and the part elements. (An alternate connection technique is to use beam bonded contact (p. 99), as described in Advanced Topics.)

After you have meshed the STL Supports, insert the AMCONNECT macro with a Commands object in both the transient thermal and static structural analyses:

1. Click the **Transient Thermal** object and select **Commands** from the context menu. Or, right-click and select **Insert > Commands**. In the Commands window that is displayed, copy and paste, or type, the following:

```
AMCONNECT, PARTID, SUPPORTID
```

but replace numbers for **PARTID** and **SUPPORTID**, where:

- **PARTID** is the type ID of your part or your support; *whichever mesh is coarser*.
- **SUPPORTID** is the type ID of your support or your part; *whichever mesh is finer*.

To determine IDs, simply count bodies in the project tree. For example, in the curved bar example, the part ID = 1, the baseplate ID = 2, and the STL Support ID = 3. The AMCONNECT macro entry is AMCONNECT, 3, 1 since the part mesh is finer than the support mesh.
2. Click the **Static Structural** object and select **Commands** from the context menu. Or, right-click and select **Insert > Commands**. In the Commands window that is displayed, copy and paste, or type, the following:

```
AMCONNECT, PARTID, SUPPORTID
```

Once you have inserted the AMCONNECT macro into both the transient thermal and static structural analyses, the proper connections (via constraint equations) will be made automatically during solution.

3. Finally, you may need to account for intrusion, or penetration, of support walls into the baseplate that may be present in your STL Support by adjusting the build-to-base contact connection.

Create the contact connection between the build and the base. Highlight the **AM Process** object and then select the **Create Base to Build Contact** option on the context toolbar. This automatically creates the contact connection. It is important to make sure the connection is valid by examining the Build Contact Element Faces and the Base Contact Element Faces objects in the project tree under Named Selections. If they have green check-mark icons in front of them, they are OK. However, if the support walls in your STL Support had intrusion, or penetration, into the base plate specified, you may need to adjust the Lower Bound tolerance on the Build Contact Element Faces object. A good guideline is to use the Z-location at the top of the base and subtract the thickness of one build element (i.e., Z-location of base minus Layer Height). The Z-location at the top of the base is shown in the Details of the AM Process object. For example, if the Z-location is 0 and the Layer Height is 0.5, change the Lower Bound in the Build Contact Element Faces as shown below. Click **Generate** to complete the operation.
5.9. Define AM Process Steps

Go directly to procedural steps. (p. 63)

The AM process is accomplished through sequential steps that dictate how consecutive solutions are performed in the overall simulation, as follows:

Minimally, there will always be a build step in both the thermal and structural portions of the simulation and usually there is a cooldown step. Additional steps may be added to the structural analysis to account for the removal of supports and/or the build from the base plate as shown here:

In most cases, base removal is done before support removal. It is important to note that residual stress and distortion results may be affected by the order in which you remove supports. The Mechanical application can simulate any scenario of support removal. You use the AM Process Sequence worksheet to specify the desired sequence.

Other solution steps, such as heat treatment steps and user-defined user steps, may be added as shown here:
Heat treatment steps may be added before or after removal steps.

A user step includes a solve execution and may be added at various points in the overall sequence. In the application, a user step effectively leaves the AM simulation environment and enters the usual nonlinear "load step" environment. Any valid loading and load step options may be used. One example of a user step is a bolt pretension step before the build. Another example could include a set of three user steps inserted before the removal steps:

1. US1 - unbolting the base plate to take for heat treatment
2. US2 - entire assembly heated to near melt
3. US3 - cooldown to room temperature again

**Procedural Steps**

For AM Process Simulations, the Mechanical application provides an alternative to the ordinary step-manipulation in analysis settings by using a custom worksheet called AM Process Sequence. Overall viewing and control of the steps in your simulation is done through this Sequencer, shown below. You can access the Sequencer button only when the AM Process object is selected in the project tree. You can toggle the display on and off using the button any time the AM Process object is selected. As illustrated, this worksheet enables you to view, and change, the steps for the transient thermal analysis and
the downstream static structural analysis, conveniently shown side-by-side. Note that unless you use a Commands object, using the Sequencer is the only way to manipulate steps in an AM Process Simulation.

1. Select the AM Process object and then select the AM Process Sequence option on the context toolbar (or click on Worksheet in the main menu bar).

2. To simulate the removal of the base or supports after cooldown, click Add Step at the bottom of the Static Structural side of the worksheet. The dropdown will show the options available for removal, depending on your set-up (Base, Predefined Support, Generated Support, and/or STL Support). You may reorder the steps in the sequence using drag and drop of one step on top of another.

3. To add a heat treatment step, click Add Step on the Static Structural side of the worksheet and select Heat Treatment Step. Additional steps are required to complete the heat treatment step as described in the advanced topic Simulating Heat Treatment after the Build (p. 87).

4. To add a user step to either analysis, click Add Step on the desired side of the worksheet and select User Step. In subsequent steps you will need to specify your step conditions, such as an extra boundary condition,
etc. If you want to insert a user step as the first step in the sequence before the thermal build step, click Add Step and choose User Step Prior to Build.

**Note:**

Advanced ANSYS users frequently combine Mechanical APDL commands with the automatic execution of models set up in Mechanical for more precise and custom control over a solution. For example, you may insert a Commands object under the Static Structural or Transient Thermal environment objects in the project tree. In the Commands object Details view, there is a useful option to Issue Solve Command (either Yes (default) or No). It enables users to better control how the commands in the Commands object are processed relative to the step execution in the Sequencer.

### 5.10. Define Build Settings

Go directly to procedural steps. (p. 66)

In this step, you specify the settings and conditions related to the machine and the process, grouped into the following three categories:

**Machine Settings** refer to process parameters which vary for each AM machine as well as for the material used in the deposition process. Inputs for machine settings are used to calculate the real, physical time duration of the build process so that the cooldown time can be determined.

- Inherent Strain (Yes or No): An option to use the Inherent Strain method (p. 84).

- Strain Scaling Factor: An optional input that scales the thermal strains in the structural portion of AM simulations by a given value. This factor is usually used to calibrate your particular machine and material.

- Deposition Thickness: The thickness of added material; that is, the amount the base plate drops between layers.

- Hatch Spacing: The spacing between adjacent scan lines when rastering back and forth with the laser.

- Scan Speed: The average speed at which the laser scans, excluding jump speeds and ramp-up and ramp-down speeds.

- Dwell Time: The span of time from the end of the laser scan of one layer to the start of the laser scan of the next layer. It includes the time required for recoater-blade repositioning and powder-layer spreading.

- Dwell Time Multiple: The dwell-time multiplier accounts for more than one part in the build. If they are the same part arranged in the same orientation on the build plate, the multiplier is the number of parts. If different parts exist on the plate, the multiplier is an estimate of the time required to build the other parts relative to the part being simulated.

- Number of Heat Sources: For multiple-beam printers, specifies the number of lasers.

**Build Conditions** are the settings pertaining to the environment in the build chamber around the part as it is being printed, including the preheat temperature.
During a PBF print process, almost all the heat dissipation is conducted through the part back to the build plate rather than out through the unmelted powder surrounding the part. Many users ignore the small effect of heat loss through powder but you may choose to model it as equivalent heat convection.

- **Preheat Temperature**: The starting temperature of the base plate.
- **Gas/Powder Temperature**: Temperature of the gas and the powder in the build chamber. You do not need to specify the same temperature for both.
- **Gas Convection Coefficient**: Convection coefficient from the part to the gas in the chamber. For the PBF process, the convection is applied only to the top of a newly deposited layer. (For a DED process, convection is also applied to the sides of the build.)
- **Powder Convection Coefficient**: Effective convection coefficient from the part to the powder bed. To estimate, divide the conduction property of the powder (KXX) by a characteristic conduction length into the powder (for example, a quarter of the distance from the part boundary to the build-chamber wall). Typically this is a very small value and is oftentimes ignored.
- **Powder Property Factor**: A knockdown factor used to estimate the powder properties. The Mechanical application applies the factor to the solid material properties to estimate the properties of the material in its powder state. The powder-state properties are used in the newly added layer during the heating of the new layer (before its subsequent solidification and cooldown) prior to the next layer being applied. The default value is 0.01.

This powder knockdown factor is also used if **powder is explicitly modeled** (p. 97) in the build.

**Cooldown Conditions** are the settings pertaining to the environment in the build chamber around the part in the cooldown step after the last layer is printed.

- **Room Temperature**
- **Gas/Powder Temperature**: Temperature of the gas and the powder in the build chamber. You do not need to specify the same temperature for both.
- **Gas Convection Coefficient**: Convection coefficient from the part to the gas in the chamber. In this cooldown step, the convection is applied only to the top layer.
- **Powder Convection Coefficient**: Effective convection coefficient from the part to the powder bed. To estimate, divide the conduction property of the powder (KXX) by a characteristic conduction length into the powder (for example, a quarter of the distance from the part boundary to the build-chamber wall). Typically this is a very small value and is oftentimes ignored.

**Procedural Steps**

You can go back to Workbench and select the Engineering Data tab at any time to see properties for your chosen material.

1. Select the **Build Settings** object (under AM Process object).
2. In Details, enter values for all the items under **Machine Settings**, **Build Conditions**, and **Cooldown Conditions**. Or, you can load a pre-saved file of build settings if you have one – right-click **Build Settings** and select **Load Build Settings**. (We provide generic sample files for our AM materials in the ANSYS Inc directory, for example: C:\Program Files\ANSYS Inc\v193\aisol\DesignSpace\DSPages\SampleData\AdditiveManufacturing. The ANSYS directory on your machine may not be on the C drive.)
3. Right-click the **Build Settings** object and select **Save Build Settings** to save your inputs to an .xml file that can be reused.

### 5.11. Establish Thermal Analysis Settings

Thermal analysis settings allow customization of various options during the transient thermal solution.

The transient thermal analysis will determine the temperature history during the build process. These temperatures will then be used in a static structural analysis to determine the build distortions and stresses. The Mechanical application will automatically determine all the steps and times needed for time integration in the simulation.

An option is available to limit the number of layers to build in the simulation, that is, to simulate only a partial build process. This may be useful if you want to examine results in the lower portion of the build if you suspect there will be cracks or blade interference there.

By default, output controls are set to suppress most result items except nodal temperatures to reduce the size of the result file. Nodal temperatures are stored at all time points by default.

**Procedural Steps**

Usually it is appropriate to leave most analysis settings set to "program-controlled." These settings are determined when you insert the AM Process object into the project tree. There are a couple of settings to note related to an AM Process Simulation, as described below.

- If you want to limit the number of layers to build in the simulation, select the **Analysis Settings** object under the Transient Thermal object and in Details, **Additive Manufacturing Controls**, change the **Layers to Build** to your desired value. Your result file will show results from the beginning layer only through the specified layer. (Note that if you change the value of Layers to Build and you want to set it back to All, enter 0.) Pay attention to the active step as indicated at the top of the Details panel under Step Controls. The number of Layers to Build in the Cooldown Step will always equal the number of Layers to Build in the Build Step.

- In Details of **Analysis Settings**, review the **Output Controls** and adjust them according to your needs. For an AM Process Simulation, your result file will grow in size very quickly, so we recommend you keep the default settings that will suppress calculation of thermal flux, nodal forces, Euler angles, volume and energy, and other miscellaneous items. To change the option of when to store element results for the Build Step, select **Store Results At** and choose All Time Points, Last Heating and Cooling Steps, or Every N Layers. (Layers refers to finite element layers, not powder deposition layers.)

### 5.12. Apply Thermal Boundary Conditions

In the Build Settings step of our workflow, we have already accounted for convection between the build and the gas in the chamber and convection between the build and the unmelted powder around the part—in both the Build Step and the Cooldown Step. There is one other area of heat transfer to consider and that is associated with the base plate.

During the build process, the plate is typically heated on the bottom to maintain a constant, slightly elevated temperature. You may insert a temperature constraint or convection surface to simulate this during the build step. If the plate is not heated, perhaps apply a room condition convection surface or set the surface boundary condition to adiabatic.
After the print process is complete, the base plate heating is removed and the built part cools to room temperature. This is simulated by a room-temperature convection surface applied to the bottom of the base plate in the cooldown step.

The time duration of the cooldown step is estimated based on the average part temperature at the end of the build, its volume, and material properties. Using the convection values and room temperature, the Mechanical application solves the simple heat transfer equation to get an estimate of the cool down time. It is only an estimate so you can extend it if required or put in a preferred time in analysis settings. One final step is done to force all the temperatures to room temperature for the subsequent distortion and stress calculation.

**Procedural Steps**

To apply a temperature to the bottom surface of the base plate for the build step:

1. Right-click the **Transient Thermal** object and then select **Insert > Temperature**.
2. Select the bottom surface of the base plate (geometry selection) and hit **Apply** in the Details view.
3. In Details under Definition, **Temperature**, enter a temperature value for **Magnitude**. (In our example we use 80°.)
4. In the **Tabular Data** area of the interface, notice the temperature value you just entered is applied for all sequence steps. (The first row of tabular data is considered T=0, the preheat condition.) In the printing process, since the heat is removed after the part is printed, you’ll need to remove the temperature boundary condition for the cooldown step of the simulation. Right-click in the third row and click **Activate/Deactivate at this step!** which will deactivate (remove) the elevated temperature for the cooldown step.

To apply room-temperature convection to the bottom surface of the base plate for the cooldown step:

1. Right-click the **Transient Thermal** object and then select **Insert > Convection**.
2. Select the bottom surface of the base plate (geometry selection) and hit **Apply** in the Details view.

3. In Details under Definition, **Film Coefficient**, enter a value for the convection coefficient.

4. Under **Ambient Temperature**, enter a value of 22°. (This may be the default.)

5. In the **Tabular Data** area of the interface, select the first two rows, right-click and select **Activate/Deactivate at this step!** which will deactivate (remove) the convection for the build step.

![Convection is active for only the cooldown step]

### 5.13. Solve the Transient Thermal Analysis

Some users prefer to solve the thermal analysis first to observe how the simulation is progressing while others prefer to set up everything and run both the thermal and structural analyses at once. Either way is perfectly acceptable. To run them both at once, simply execute a solve from the static structural side and the transient thermal analysis will be run first automatically.

Since the solution can take significant time to complete, a solution status window is provided that indicates the overall progress of the solution. Other solution trackers and tools allow you to i) view the actual output from the solver, ii) graphically monitor items such as convergence criteria, and iii) view the temperature contour as the build progresses. You can also monitor some result items such as temperature at a node as the solution progresses.

### Procedural Steps

1. To set up a plot of overall temperature that will be updated throughout the solution, under Transient Thermal, Solution, **Solution Information**, select **Insert > Temperature Plot Tracker**.

2. Right-click the **Temperature** plot tracker object and select **Switch to Automatic Mode**. This will show a live display as the solution progresses. Note that the plot tracker object must be selected in order to see the live display.

3. To initiate the solution, under Transient Thermal, highlight the **Solution** object, right-click and select **Solve**.

### 5.14. Establish Structural Analysis Settings

Structural analysis settings allow customization of various options during the static structural solution.

The Reference Temperature is the temperature at which thermal strains do not exist in a material. In the simulation of the AM process, our assumption is that each finite element super layer is added (with the element birth/death technique) at the melting temperature for the material and is initially strain-free. (We set \( T_{ref} = T_{melt} \) by default.) As the build cools, thermal strains develop. The static structural analysis will use the temperature results of the transient thermal analysis to compute the displacements, stresses, strains, and forces due to these induced thermal strains.
If you will be simulating a heat treatment process such as annealing after the build, you will probably want to specify a Relaxation Temperature. Lower than the melting temperature, the relaxation temperature is the temperature at which strains begin to soften. (Using a creep model in Engineering Data is an alternative stress relaxation mechanism.) Refer to the advanced topic Simulating Heat Treatment after the Build (p. 87) for details.

As stated for Thermal Analysis Settings, we recommend you think about using options to reduce the amount of data stored. You may want to suppress the calculation of stresses and strains if you’re only interested in distortion, as these data will easily increase the size of the result file and it may become unmanageable. Additional controls allow you to specify when to store results for the build step; for all layers, for the last heating and cooling steps, or every N layers.

Should you use the option to limit the number of layers to build in the simulation, the number specified must be not more than the number of layers to build used in the thermal analysis step.

**Procedural Steps**

As with the thermal analysis, many analysis settings in the structural analysis are program-controlled.

- Select the Analysis Settings object under the Static Structural object and in Details, note the Additive Manufacturing Controls. The Reference Temperature is automatically set to the material’s melting temperature. (You can see this value in Engineering Data for your chosen material.)

- If you added a Heat Treatment Step in the AM Process Sequencer, you will probably want to specify a Relaxation Temperature. Under Additive Manufacturing Controls, change the Relaxation Temperature to User Specified and change the Value to the appropriate temperature. See the advanced topic Simulating Heat Treatment after the Build (p. 87) for additional steps to complete the Heat Treatment Step.

- To limit the number of layers to build in the simulation, under Additive Manufacturing Controls change the Layers to Build to your desired value. The number specified must not be more than the number of layers to build used in the thermal analysis.

- Review the Output Controls and suppress items not of interest. To turn off calculation of stress and strain, change Yes to No. (Hint: Simply double-clicking in the Yes box changes it to No.) To change the option of when to store results, select Store Results At and choose All Layers, Last Heating and Cooling Steps, or Every N Layers.

### 5.15. Apply Structural Boundary Conditions

Unless you specified a base removal step, the only boundary condition that must be applied is a fixed support boundary condition on the build plate. If a base removal step is included, you need to apply fixed boundary conditions on three nodes of the part to prevent rigid body motion when the base is removed.

**Procedural Steps**

Under the Static Structural object, notice there is already an Imported Load object. This is the result of the linked analysis system and represents the temperature results from the transient thermal solution.

1. To fix the bottom surface of the base plate, right-click the Static Structural object and then select Insert > Fixed Support. Select the bottom surface of the base plate (geometry selection) and hit Apply in the
Details view. If you have a more detailed geometry for the base, such as one with bolt holes that you want to explicitly simulate, apply the boundary conditions to affix the plate accordingly.

2. If you specified a base removal step, you'll need to constrain the part at three nodes to prevent rigid body motion. Note that you will be constraining the nodes to their displaced position at the end of the build, rather than constraining them to 0. (For example, if the node displaced 0.1 mm during the simulation, the constraint will keep the node at 0.1 mm.) Use a Commands object to do this.

   a. You may want to hide the base body during this process. Right-click the base body and select Hide Body.

   b. Zoom in to the area of the part where you will apply constraints. Switch to Node mode of selection.

   c. Create nodal Named Selections: Right-click Model in the project tree, and select Insert > Named Selection. Select a node on the bottom of the part, perhaps toward the middle of the part. You should choose nodes that are unimportant to your results. Perhaps spread them out over the bottom of the part but the nodes must not be co-linear. Your node selection will affect displacement results but not stresses or strains. Click Apply in Details. Right-click the newly created Selection in the project tree (under Named Selections) and select Rename. Name it to something short and descriptive, such as CN1 (for constrained node 1). Do the same step two more times and rename them to CN2 and CN3.

   d. Create commands to constrain the nodes: Click the Static Structural object and select Commands from the context menu. Or, right-click and select Insert > Commands. In the Commands window that is displayed, copy and paste, or type, the following:

```
71
```

Release 2020 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates. 71
Constrained node 1 is fixed in UX, UY, and UZ and holds the part in place. Constrained node 2 is fixed in UY and UZ, and constrained node 3 is fixed in UZ; these prevent rotation. Selection of CN1 can have a big effect on the displacement throughout the part. See the D command, which defines degree-of-freedom constraints at nodes, for more information.

**e.** Match the commands to the base removal sequence step: Select the newly created Commands object under Static Structural and, in Details, change the Step Selection Mode to By Identifier. Change the Step Number to Removal Step: Base. This ensures the constraints are applied just before the base removal step.

**f.** Remember to make the base plate visible again if you hid the body. Right-click the base body and select Show Body.

### 5.16. Solve the Static Structural Analysis

Watch live trackers plot the total deformation as the solution progresses.

**Procedural Steps**

1. To set up a plot of overall deformation that will be updated throughout the solution, under the Static Structural object, Solution Information, select Insert > Deformation Plot Tracker.

2. Right-click the Total Deformation plot tracker object and select Switch to Automatic Mode. This will show a live display as the solution progresses. Note that the plot tracker object must be selected in order to see the live display.

3. To initiate the solution, under Static Structural, highlight the Solution object, right-click and select Solve.

### 5.17. Review Results

Once a solution is available you can contour the results or animate the results. You will have solutions at many time points and you can display the variation of the result item at a location over the build history.
A significant concern in additive manufacturing is whether the build will print successfully without experiencing blade interference (sometimes called blade crash). This phenomenon occurs when the powder recoater blade hits into a portion of the built part that has deformed extensively because of residual stresses. Usually the result is a stopped process and a failed build. You can check for this in the simulation by viewing an animation of the deformation in the Z direction and comparing to your threshold limit, such as double the deposition thickness.

At times you may want to obtain results along an edge or other specific location of the part to determine if the part will be within tolerances or to compare to distortion measurements made after the part is built. There are several ways to do this.

Finally, an estimate of the real 3D printing time is available in the solution as well.

**Procedural Steps**

Recall that you used Output Controls under Analysis Options to control which items are solved for in the simulation. You also may have set up results trackers in the solution step to observe the results being processed during the solution. When reviewing results *after* the solution, you will generally need to *evaluate* results to obtain them for viewing. Evaluating results is a way to retrieve them from the data that was stored during solution. Only data items that were solved for may be retrieved in this way.

There are many different ways to view results but some of the ones most commonly used for additive manufacturing are described here:
Animate Thermal Results - Temperatures

1. In the project tree under Transient Thermal, select the Solution object and then, in the context menu, click Thermal and then Temperature. Or right-click Insert > Thermal > Temperature. A Temperature object is created and becomes active.

2. Right-click Temperature and select Evaluate All Results. This retrieves the temperature data and displays it in both graph and tabular form.

3. Use the animation controls at the top of the Graph window. Click the Result Sets button and also the Update Contour Range at Each Animation Frame button. Adjust the number of seconds for the animation and click Play. See Animation in the Mechanical User's Guide for more information about animation controls.
Animate Structural Results - Total Deformation

1. In the project tree under Static Structural, select the **Solution** object and then, in the context menu, click **Deformation** and then **Total**. A Total Deformation object is created and becomes active.

2. Right-click **Total Deformation** and select **Evaluate All Results**. This retrieves the deformation data and displays it in both graph and tabular form.

3. Use the animation controls at the top of the Graph window.

4. It is important (and fun!) to change the magnification scale of the display in the Geometry window so you can get a true sense (or an exaggerated sense) of the deformation in your build. With Total Deformation highlighted in the project tree, from the **Result** context tab, select the **True Scale** option from the drop-down menu. Animate the results using the animation controls. Select other scales from the drop-down menu to see exaggerated results.

The following is an animated GIF. Refresh the page to see the animation. View online if you are reading the PDF version of the help.
Check for Blade Interference

Note:
At this release, a Blade Interference Tool is available as a Beta feature. It will predict where blade interference will occur during the build process. Use the Blade Interference Tool in lieu of the procedure described next.

1. Right-click the Directional Deformation object and select Evaluate All Results.

2. In the legend area of the Geometry window, double-click the lower limit of the uppermost color bar (red) to insert your own number. Enter a number that represents a threshold limit for blade interference. Consider using twice the deposition thickness. Rotate your model so you can see a top-down view and then animate the Directional Deformation results. If you see red contours, those are locations of concern for blade crash. Note that the image below does not show deformation above the threshold on the top layer, which is the layer of concern for blade interference. (Rotating the model for a top-down view, which we did not do in this figure, makes it easier to view the top layer.)
Scope a Line of Nodes to Get Results in Specific Locations

Suppose you want to obtain X-direction deformation along a line on a face of your part, such as shown below, at the end of the cooldown step.

There are several ways to perform this function but we will demonstrate it using a Worksheet. To obtain distortion results along a line on the surface of your part:

1. Create a Named Selection: Highlight the Model object, right-click and select Insert > Named Selection. Right-click the newly created Selection object (under Named Selections) and Rename to something meaningful, for example, Line of Nodes.
Get an Estimate of the Actual 3D Printing Time

View the solver output to get an estimate of the real machine build time. It is approximately the transient thermal build step simulation time multiplied by $R^{(1/3)}$, where $R$ is the number of deposit layers in one element layer. This data is available after the thermal solution. Click the Solution Information object and then click the Worksheet tab under the Geometry window. In the Details view, be sure that Solver Output is selected as Solution Output.
Chapter 6: Advanced Topics

This chapter describes additional topics that you may want to consider for AM Process Simulations, including the following:

6.1. Using Topology Optimization for Additive Manufacturing  
6.2. Using the Inherent Strain Method  
6.3. Performing a Directed Energy Deposition (DED) Process Simulation  
6.4. Simulating Heat Treatment after the Build  
6.5. Capturing a Buckled Shape with Large Deflection  
6.6. Modeling a Symmetrical Part  
6.7. Modeling Powder with Elements  
6.8. Modeling Clamps, Measuring Devices and Other "Non-Build" Components  
6.9. Using Beam Bonded Contact to Connect a Tet-meshed Part to STL Supports  
6.10. Troubleshooting Convergence Issues

6.1. Using Topology Optimization for Additive Manufacturing

Topology optimization is an exciting technology that allows designers to optimize material layout within a given design space, for a given set of loads, boundary conditions and constraints, with a goal of maximizing the performance of a product. The optimal shape of a part is often organic and counter-intuitive, and difficult or impossible to manufacture using traditional methods. By its very nature, additive manufacturing opens up whole new possibilities for the real-world production of these optimized parts. Along with the potential gains comes challenges unique to the manufacturing process, however. We've seen that the use of supports for overhanging features during the printing process is necessary but costly. If we could optimize our product designs while minimizing the requirement for supports at the same time, we will be taking advantage of the best of both technologies.

The AM Overhang Constraint available in ANSYS Mechanical's topology optimization tools allows us to do just that. The goal of the overhang constraint is to create a self-supporting structure so that it may be printed without adding supports. We will examine the overall workflow of using topology optimization combined with AM Process Simulation as well as the specific usage of the overhang constraint in this section. See Topology Optimization Analysis for a general discussion of how this technology is implemented in ANSYS Mechanical.

Topology Optimization and AM Process Simulation Workflow

The general workflow in a linked topology optimization and AM simulation is shown in the following figure.
Step A – Run an initial static structural analysis to establish loads and boundary conditions and baseline results in Mechanical.

Step B – Run the topology optimization analysis with the AM Overhang Constraint in Mechanical.

• Highlight **Topology Optimization**, right-click and select **Insert > AM Overhang Constraint**. In Details, change **Build Direction** and **Overhang Angle** to your desired values.

  Parts designed using the AM Overhang Constraint are constrained more and results will include more material than those optimized without the constraint. To allow more flexibility in solving this highly nonlinear problem, we recommend you specify a **range** for the response constraint rather than just a constant value. For example, if you want to reduce the mass in your part by 70%, we recommend you allow the program to use a Percent to Retain range between 25 and 30% for maximum flexibility in the algorithm. Defining a range for response constraint in combination with overhang constraint will frequently require fewer iterations.

• Under Topology Optimization, select **Response Constraint**. In Details, under Definition, choose **Mass** or **Volume** for **Response**. Change **Define By** to **Range** and enter a range of values for **Percent to Retain** Min and Max.

Step C – Clean up the optimized geometry in SpaceClaim and then validate the design in Mechanical. Search for the Additive Manufacturing section in the SpaceClaim documentation. Also, see **Performing Design Validation in the Mechanical User's Guide**.

Steps D and E – Run the additive manufacturing simulation on the optimized design in Mechanical.

**AM Overhang Constraint Methodology**

The AM Overhang Constraint is defined by a printing direction and an overhang angle. The printing direction can be one of the global coordinate system axes (either the positive or negative direction).

The overhang angle restricts the state of optimized elements. (Optimized elements are those that are "kept" in the final design and that contribute to the system's overall stiffness matrix; i.e., are filled with material.) An element will be kept only if there is a supporting element in the layer below (or above depending on the printing direction) that is also filled with material. An element is called a supporting element of another element if the angle between the line defined by their centroids and the base plate...
is greater than, or equal to, the overhang angle. The following figure demonstrates the restriction with an overhang angle of 45° in 2D. The printing direction is from the bottom to the top. In order to fill the yellow element with material, at least one of the blue elements has to be filled, too. Which of the blue elements will be kept depends on the state of the surrounding elements as well as the load path. In the final design all remaining optimized elements have supporting elements.

**Base Plate**

The surface of the base plate is a plane perpendicular to the build direction. The base plate touches the design region from below for positive printing direction (or from above for negative ones). For a design to be printable, it requires a connection to the base plate. The results will depend on the size of the area of contact. Results of the optimization will improve with increased contact area.

**Excluded Elements**

Excluded elements in the design region can lead to designs that do not satisfy the overhang constraint. It cannot be guaranteed that these excluded elements are supported with respect to the overhang angle. Excluded elements are always considered to provide support to optimized elements.

**Example of AM Overhang Constraint Used in Topology Optimization**

As shown in the following figure, a bracket-type component has two counterbored bolt holes at one end and a through hole going through two flanges at the other. The bolt holes are fixed and a remote force is applied to the two holes of the flanges. These regions are excluded from the topology optimization and are shown in red. The remainder of the geometry is our design region (purple). We want to minimize material on the component while still maintaining its ability to structurally support the loads.
We used topology optimization first without, and then with, the AM Overhang Constraint. We set a mass response constraint range of 10-13% material to retain. When using the AM Overhang Constraint, we set an overhang angle of 45°. The print (or build) direction is from 0 along the positive Z axis.
Without AM Constraint
Comparing the two models, you can see there are several surfaces that will require supports in the first image, especially underneath the branched structures. While not entirely eliminating them, the second model minimizes these surfaces. Note also that the through holes will need to be supported during 3D printing. The hole surfaces were not modified, as they were excluded regions.

6.2. Using the Inherent Strain Method

The Inherent Strain method provides an alternative to the typical coupled thermal-structural additive process simulation available in Workbench Additive. With the Inherent Strain method, strains are calculated not from material properties and thermal loads but from the use of a Strain Scaling Factor. The strain is equal to the Strain Scaling Factor multiplied by yield strength and divided by elastic modulus:

\[ \varepsilon = \text{SSF} \times \frac{\sigma_{\text{Yield}}}{E} \]

The Strain Scaling Factor (SSF) is an important factor quantifying the variables unique to each build scenario. It must be experimentally determined for each machine and material combination of interest. We recommend you perform the same calibration procedure used for ANSYS Additive, as described in the Additive Calibration Guide (available online here).

The steps in a typical additive manufacturing simulation are listed below. Most of these steps remain the same when using the Inherent Strain method. Steps shown in bold include changes for the Inherent Strain method:

1. **Create the Analysis System**  Static Structural system only. (Do not add the Thermal Transient system.)
2. Define Engineering Data

3. Attach Geometry and Launch Mechanical

4. Identify Geometry

5. Assign Materials

6. Apply Mesh Controls and Generate Mesh

7. Identify and/or Generate Supports

8. Define Connections

9. Define AM Process Steps  Note there is no Cooldown step

10. **Define Build Settings**  In Details, set Inherent Strain = Yes, and add a Strain Scaling Factor, with either Isotropic or Anisotropic values. Define a Deposition Thickness.

    The Strain Scaling Factor (SSF) is a calibration factor used to account for differences in machines that you may use to improve the accuracy of your simulations. This value is a direct multiplier to the predicted strain values. Using a value of 1 (default) will result in strain magnitudes as calculated by the solver. Some material and geometry combinations result in bulging/expansion rather than shrinkage and so a negative SSF is possible. Values between -1 and 1 will reduce displacement and stress while values outside of that range will amplify them. Using a value of 0 will result in no strain and the final displacement will match the input geometry.

    You can define Strain Scaling Factors that are different in each direction (X, Y, and Z) by choosing Anisotropic for Inherent Strain Definition. The properties of these materials will differ in different directions.
11. Establish Thermal Analysis Settings  Not applicable

12. Apply Thermal Boundary Conditions  Not applicable

13. Solve the Transient Thermal Analysis  Not applicable

14. Establish Structural Analysis Settings

15. Apply Structural Boundary Conditions

16. Solve the Static Structural Analysis

17. Review Results

6.3. Performing a Directed Energy Deposition (DED) Process Simulation

Directed Energy Deposition (DED) is an additive manufacturing process where metal wire or powder is combined with an energy source to deposit material onto a part directly. Rather than spreading a layer of metal powder across a surface and scanning the part’s profile with a laser to build up a part surrounded
by unmelted powder, only the desired part is built in a DED process, with no surrounding leftover powder. The DED process is much less expensive than PBF but less precise. It is widely used to repair or add extra material to existing parts.

Simulation of a DED process is almost the same as for a PBF process, except that the convection of heat from the part as it is being built must be accounted for differently. Specifically, convection to the surrounding gas in the chamber is applied to all sides of the build as it is building. (This differs from a PBF simulation, in which the convection is applied only to the top of a newly deposited layer.) A DED simulation uses only the gas convection properties of the build settings and not the powder convection properties. All the required adjustments are handled automatically by the program once you specify a DED simulation using the **AMTYPE** command.

At any point prior to solution, specify a DED simulation with a Commands object in both the transient thermal and static structural analyses:

1. Click the **Transient Thermal** object and select **Commands** from the context menu. Or, right-click and select **Insert > Commands**. In the Commands window that is displayed, copy and paste, or type, the following:

   `AMTYPE,DED`

2. Click the **Static Structural** object and select **Commands** from the context menu. Or, right-click and select **Insert > Commands**. In the Commands window that is displayed, copy and paste, or type, the following:

   `AMTYPE,DED`

All other procedures for a DED simulation are the same as in a PBF simulation.

### 6.4. Simulating Heat Treatment after the Build

After a part is built (3D printed), it is common to heat treat it to relieve residual stresses. Heat treating is a process using the controlled application of heat to alter the physical and chemical properties of a material. In an annealing process, metal is heated in a furnace to a particular high temperature, held there for a long time (hours or days) and then allowed to cool slowly. This may be done either before or after removing the part from the baseplate. These scenarios can be simulated in Workbench Additive.

A separate, additional Transient Thermal analysis is required to model the heat treatment process. The workflow is shown in the following figure. The systems in the workflow show how data flows from one analysis type to another. For example, temperatures from the two (uncoupled) thermal analyses are required as inputs for the structural analysis. It is within the AM Process Sequencer that the proper time sequence—or **when that data is used**—is defined.
Overview

The modeling of heat treatment is included in the Additive Wizard. Below is an overview of the steps required to simulate heat treatment after the build without using the wizard:

- **Add a new Transient Thermal analysis system to the project schematic.**
- **Add a Heat Treatment Step in the AM Process Sequencer.**
- **Apply the convection loads to all bodies for the heat treatment step.**
- **Account for the stress relaxation mechanism in one of two ways:**
  - By specifying a Relaxation Temperature in the Static Structural analysis settings. This is a simplified approach.
  - By using a creep model in Engineering Data. This is a more stringent approach.

Add Transient Thermal System to Project

Assuming you have an AM Process Simulation already set up in ANSYS Workbench:

1. From the Analysis Systems folder, drag a new **Transient Thermal** system over the top of the existing Transient Thermal system and release the mouse when the cursor is on the Model cell.
2. Link to the Static Structural system by dragging the Solution cell of the new Transient Thermal object and release on the Setup cell of the Static Structural system.

3. Within the Mechanical application, click the new Transient Thermal object in the project tree and in the Details view, under Additive Manufacturing, change the AM Process Simulation setting to No. (By default, Mechanical assumes an AM Process Simulation should be performed for Transient Thermal systems when there is an AM Process object in the project tree.)

Add Heat Treatment Step to the AM Process Sequencer

1. Select the AM Process object and then select the AM Process Sequence option on the context toolbar.

2. Click Add Step on the Static Structural side of the Sequencer worksheet and select Heat Treatment Step. Rearrange steps in the sequencer as needed.

3. Select the Static Structural object in the project tree and then select the Imported Load object underneath it that belongs to the new heat treatment Transient Thermal system. In the Details view, under Additive Manufacturing, change the Transfer Step option to your new Heat Treatment Step.

Apply Convection Loads

To apply convection to the surfaces of the part, supports, and base plate for the heat treatment step:

1. Right-click the new Transient Thermal object and then select Insert > Convection.

2. Select all the bodies including the base plate (geometry selection) and hit Apply in the Details view.

3. In Details under Definition, Film Coefficient, enter a value for the convection coefficient or select Tabular Data.

4. Under Ambient Temperature, select Tabular Data.

5. In the Tabular Data area of the interface, specify the appropriate convection coefficient and temperature at different time points.

6. In Analysis Settings, change the Step End Time to match the final time in the convection tabular data. More details on how to control the time stepping settings are available here.

Identify Stress Relaxation Mechanism

To use a Relaxation Temperature as the mechanism for stress relief:

- Click Analysis Settings under the Static Structural object. In the Details view, under Additive Manufacturing Controls, change the Relaxation Temperature to User Specified and then change the Value to your desired stress relaxation temperature for the material.

   Alternatively, to use a creep model as the mechanism for stress relief:

1. From the Workbench Project page, double-click Engineering Data in the first Transient Thermal analysis.

2. In the Toolbox window, expand the tab for Creep and drag your desired creep model to your material. Enter information for all required fields before returning to the Project page.

3. Right click model in the first Transient Thermal analysis and select Update before returning to Mechanical.
Example Heat Treatment Project

The following heat treatment project was set up to show the effects that heat treatment can have on stress and distortion in an additively manufactured part. Two cantilevers with supports are set up in the same additive manufacturing simulation with cutoff from the supports occurring at different time points for each cantilever. The first cantilever is removed from supports before heat treatment, and the second cantilever is removed after heat treatment.

![Diagram of cantilevers]

Cantilever 1
Supports will be removed before heat treatment.

Cantilever 2
Supports will be removed after heat treatment.

To model this, the AM Sequencer was set up as shown in the following figure.
After simulating the additive manufacturing process and steps defined in the sequencer, the two cantilevers are left with different distortion magnitudes. The heat treatment step relieved residual stresses and led to decreased distortion in the second cantilever (on the left) after the cutoff step.
6.5. Capturing a Buckled Shape with Large Deflection

If your part has particularly thin walls and you are worried that it may deform significantly during the additive printing process, you can set up a simulation to capture a buckled shape deformation. The following two settings should be set to capture this phenomena in the AM simulation:

- Turn on Large Deflection: Under Static Structural, click **Analysis Settings**. In the Details view, under Solver Controls, change **Large Deflection** to **On**. This setting is off by default for AM simulations.

- Use Quadratic elements: Click **Mesh**, and in Details, under Defaults, change **Element Order** to **Quadratic**. Higher-order elements may help convergence in the simulation.

The following figures show distortion results from an AM simulation of a model with a thin outer wall. The full model is shown as well as a cross-section view. The upper portion shows significant distortion into a buckled shape. (Note: this model has a coarser mesh than recommended, it is for demonstration purposes only.)
Capturing a Buckled Shape with Large Deflection
6.6. Modeling a Symmetrical Part

If your model has symmetrical geometry (including the part, supports and the build plate), and the loading and boundary conditions are also symmetrical, you can simulate a sector of a large model to achieve a faster simulation time with fewer resources. The symmetry sector should include the base plate as well as the build (part and supports). The procedure is the same as described in Defining Symmetry with a couple unique adjustments required for the AM Process Simulation. Specifically, you will need to input a Dwell Time Multiple and create a SYMM_NODES Named Selection. These steps are described as follows:

- Input a **Dwell Time Multiple** equal to the number of symmetry sector repeats. This is required to reconcile the reduced time to simulate the build. For example, the build time for a half symmetry model is \( \frac{1}{2} \) of the build time of the full model, so the Dwell Time Multiple should be 2. Similarly, use a Dwell Time Multiple of 4 for a quarter symmetry model, and so on.

In the project tree, click **AM Process > Build Settings** and in the Details view under Machine Settings, change **Dwell Time Multiple** to 2, or 4, or the appropriate number of repeats. In the half symmetry model in the following example, we changed Dwell Time Multiple to 2.
• Create a SYMM_NODES Named Selection of nodes along the symmetry plane. This allows the program to handle the AM boundary conditions properly internally.

Right-click Model in the project tree, and select Insert > Named Selection. Right-click the newly created Selection object (under Named Selections) and Rename it to SYMM_NODES. In the Details view change Scoping Method to Worksheet. In the Worksheet, set up filtering criteria to identify the nodes of interest. In the half symmetry model below, we selected all the nodes along a plane of Y = 0.
Assuming the regular steps in an AM Process simulation (p. 11) (assigning materials, defining AM process steps and build settings, generating supports, etc.) have all been performed, we will complete the last step for the symmetry example below.

- Insert a symmetry region on the faces defining the symmetry plane of the build and the base plate. This will apply a frictionless support boundary condition on those faces. With this boundary condition, no portion of the body can move, rotate, or deform normal to the faces. (Note that the use of a frictionless support is not unique to additive manufacturing simulations.)

Switch to face mode of selection and use Ctrl-left-click to select the multiple geometry faces along the symmetry plane. Highlight Model, right-click and Insert > Symmetry. Right-click the Symmetry object and select Insert > Symmetry Region. In the Details view, change the Symmetry Normal property to Y-Axis. (This is defining the axis of the Global Coordinate System that is normal to the symmetry plane.)
6.7. Modeling Powder with Elements

During an L-PBF process, almost all the heat dissipation is through the part and supports back to the build plate rather than out through the unmelted powder surrounding the part. Many users ignore the small effect of heat loss through powder but you may choose to model it in one of two ways:

- As equivalent heat convection
- By including powder elements as a Named Selection called POWDER_ELEMENTS. (For MAPDL users, use an element component CM,POWDER_ELEMENTS,ELEM).

Modeling the powder as elements may be useful if you will be simulating multiple parts close together on the build plate or if the part has features close together, where accounting for the heat transfer occurring between the parts or features is important. The following is an overview of the procedure:

1. In your CAD program, create a separate body to represent the powder in-between the parts or features. If you will be using a Cartesian mesh, share topology between the bodies. If you will be using a layered Tetrahedrons mesh, do not share topology.

2. In the Mechanical application, identify the build and base bodies on the AM Process object as usual. Do not select the powder body when identifying the build and base bodies.

3. Assign the same material property that you use for the build to the powder body.

4. Depending on your chosen mesh type, account for the connections between bodies and mesh the model.
5. Create a Named Selection, called POWDER_ELEMENTS, of elements associated with the powder body. This ANSYS-defined Named Selection will use the knockdown factor, Powder Property Factor, identified in the Build Conditions to estimate the powder properties.

6. Proceed with the rest of the simulation as normal.

In the following example, the powder was modeled between two cylindrical parts close together on the build plate. Temperature contours are shown in the second figure. Notice the heat transfer in the powder area between the parts.
6.8. Modeling Clamps, Measuring Devices and Other "Non-Build" Components

At times you may want to simulate geometry items that are present on the build plate but that are not being 3D-printed. These items may include clamps, bolts, measuring devices, instrumentation, etc. They may influence the heat dissipation and/or distortion of the part being built so they need to be included in the simulation.

Use the ANSYS-defined Named Selection NONBUILD_ELEMENTS to identify this geometry. (For MAPDL users, use an element component CM, NONBUILD_ELEMENTS,ELEM). This ANSYS-defined component name signals to the application that those elements should not be part of the build process. In other words, they will be present the entire simulation and will not be "birthed" at melting temperature in a layer-by-layer fashion.

6.9. Using Beam Bonded Contact to Connect a Tet-meshed Part to STL Supports

If you have meshed your part with a layered tet mesh and then you imported STL Supports, which are meshed with voxels, you now have dissimilar element shapes that must be connected. Dissimilar element shapes between part and supports present a challenge in an additive simulation, particularly STL Supports that may have holes within its structure. Simulations may produce unexpectedly high or low temperature, excessive displacement, or even divergence of the solution. If you prefer not to use the AMCONNECT command macro (p. ?), another way to establish the connection is to use beam bonded contact to connect the part to the supports. Furthermore, beam elements will need to be defined as non-build components to hold the model together at all times in the simulation, including before the layers are "made alive." By making them non-build components, the elements may cross the layer boundaries.
Finally, you may need to account for intrusion, or penetration, of support walls into the baseplate that may be present in your STL Support by adjusting the build-to-base contact connection.

The following is the procedure for establishing contact using beams:

- Right-click **STL Support** and select **Create Named Selection of External Faces**. A new Named Selection is created under Named Selections. Rename it to **STL e-faces**.

- Create a Named Selection representing the part. Right-click **Named Selection** and **Insert, Named Selection**. Select the part geometry and click **Apply** in the Details view. Rename the new selection **Part**.

- Create a Named Selection of part element faces. Right-click **Named Selection** and **Insert, Named Selection**. In Details, change the Scoping Method to **Worksheet**. Set up the worksheet using selection operations as shown below. Click **Generate**, and then rename the selection to **Part e-faces**.

- Right-click **Connections** and select **Insert, Manual Contact Region** for beam bonded contact. Under Details, set the following:
  - Scoping Method = Named Selection
  - Contact side = STL e-faces, Target side = Part e-faces
  - Type = Bonded
  - Trim Contact = On
  - Trim Tolerance = same as mesh Layer Height
  - Formulation = Beam
  - Material = same as build material
  - Radius = about 10% of the mesh Layer Height

Lastly, right-click the bonded contact object and select **Rename Based on Definition** to automatically rename the connection.

- Insert a Commands object into both the Transient Thermal and Static Structural environments to create non-build elements components for the beam elements.
  - Use Beam 33 elements in Transient Thermal environment. Right-click **Transient Thermal** and select **Insert, Commands**. Copy and paste (or type) the following:
Use Beam 188 elements in Static Structural environment. Right-click **Static Structural** and select **Insert, Commands**. Copy and paste (or type) the following:

```
esel,s,ename,,188
cm,nonbuild_elements,elem
allselect
```

Finally, create the contact connection between the build and the base. Highlight the **AM Process** object and then select the **Create Base to Build Contact** option on the context toolbar. This automatically creates the contact connection. It is important to make sure the connection is valid by examining the Build Contact Element Faces and the Base Contact Element Faces objects in the project tree under Named Selections. If they have green check-mark icons in front of them, they are OK. However, if the support walls in your STL Support had intrusion, or penetration, into the base plate specified, you may need to adjust the Lower Bound tolerance on the Build Contact Element Faces object. A good guideline is to use the Z-location at the top of the base and subtract the thickness of one build element (i.e., Z-location of base minus Layer Height). The Z-location at the top of the base is shown in the Details of the AM Process object. For example, if the Z-location is 0 and the Layer Height is 0.5, change the Lower Bound in the Build Contact Element Faces as shown below.

![Build Contact Element Faces](image)

### 6.10. Troubleshooting Convergence Issues

If you are experiencing convergence issues during an AM Process Simulation, try one or more of these suggestions, as appropriate:

- If Large Deflection is on, turn it off, under Analysis Settings for the static structural analysis. Large deflection is off by default for AM Process Simulations but it is useful in some cases and users often turn it on.
  - For thin-walled parts, the walls can tend to take on a buckled or dimpled shape as the build progresses. In these cases, large deflection is required and convergence difficulties may be seen. If that is the case, you will need an adequate mesh to capture this deformation. Consider using a finer mesh or switch to a quadratic (midside-noded) element (Element Order in Mesh Details). See Capturing a Buckled Shape with Large Deflection (p. 92) for details.

- Switch to the Direct Solver for Solver Type under Analysis Settings for the static structural analysis.

- If you are using customized materials, be sure you have defined a nominal strength at the melt temperature, as a near zero modulus and/or yield strength could lead to convergence problems. (ANSYS pre-defined materials take care of this internally.)
• If using a Layered Tetrahedrons mesh with a geometry imported from an .stl file, be sure the faceted geometry is cleaned up as much as possible. (See Cleanup of Facets (p. 7)). Depending on the quality of the .stl file, you may see convergence issues because of poor tet elements created with a "dirty" .stl file.